Adding Gmail account: "Your browser is not supported anymore"

razor1973

New member
Aug 16, 2008
49
0
0
Visit site
I upgraded from 8.1 directly to 10586.218 on my AT&T Lumia 1520 via Insider Release Preview ring, then did a hard reset and restored from backup. As usual, I had to retype the passwords of my non-Gmail e-mail addresses and authenticate the Gmail ones via the page. However, to my surprise, I now encounter the attached error, which doesn't allow me to even enter the user name. I tried adding as a new Gmail address and get the same error. How can I work around this? How are you supposed to add a Gmail account on Windows 10?

wp_ss_20160415_0001.jpg

EDIT: In case someone ends up finding this thread while searching for the same problem, I found a workaround. Go into the settings of Edge browser, set the preference to Desktop instead of Mobile page, press back to exit settings and then back again to exit Edge. Then, try adding or fixing your Gmail account again. This worked for me. Remember to go back to the Edge settings and change your preference to Mobile. Well, unless you prefer the Desktop setting, of course.
 
Last edited:

maka1105

New member
May 22, 2013
12
0
0
Visit site
Try this. Edge settings-website preference-chose desktop version. Than try to add or verify gmail account.
I also have problem to open gmail on mobile site in edge. It's opened in old mobile version of gmail.
Lumia 640 XL DS.
 

ruserious87

New member
Mar 19, 2016
14
0
0
Visit site
I'm having the exact same problem on my L1520 as well. really looking for incite I didn't realize how much i relied on that email account.
 

razor1973

New member
Aug 16, 2008
49
0
0
Visit site
In my case, that's 100%. That Gmail account is my primary personal Gmail account. That means I cannot receive or send e-mail on my phone. Nice.
 

razor1973

New member
Aug 16, 2008
49
0
0
Visit site
So what maka1105 suggested above did work. I had already tried this once, but I never exited the Edge browser before trying to add my account again. This time around, I changed the setting, pressed Back to exit and save settings and then, back again to exit the browser. Once I attempted to add my Gmail account again, this worked.

I wanted to let you who are also having this problem know and I edited my original post in case someone else finds this.
 

anthonyng

Active member
Nov 29, 2012
1,867
0
36
Visit site
The gmail in edge browser sucks now too. Turned to basic HTML mode, no more nice App type experience in browser, and this is on w10 production
 

snakebitten

New member
Dec 1, 2012
417
0
0
Visit site
I gave in and added my gmail account to the Outlook app. I WAS rather enjoying the sweet web-based render in Edge Mobile, and the features that were very slick. But alas, the temporary harmony has apparently ended.
 

Maurizio Troso

New member
Aug 22, 2014
4,692
0
0
Visit site
I gave in and added my gmail account to the Outlook app. I WAS rather enjoying the sweet web-based render in Edge Mobile, and the features that were very slick. But alas, the temporary harmony has apparently ended.

Turn back to production ring, goofle and ms are not friends.... thanks to google
 

maxmin

New member
Mar 14, 2013
57
0
0
Visit site
I tried setting edge to desktop version. Didn't work. Even tried to restart phone. Still got the browser not supported message. Any ideas? Will advise if I find solution.
 

Norre49

New member
Aug 5, 2016
5
0
0
Visit site
Hei

I having the same problem with a Lumia 1520 and 640 XL. Funny thing here is that earlier I was able to add my Gmail account, but now two days later when I try to put another Gmail address, it fails!
 

rhapdog

Retired Senior Ambassador
Aug 26, 2014
3,035
0
0
Visit site
Best option is to convert to an outlook.com account in my opinion. Eschew all things Google.

Sorry, I just hate Google that much.
 

Members online

Forum statistics

Threads
322,530
Messages
2,242,206
Members
427,948
Latest member
danielaatrs