All my side buttons just stopped working... any fix or workarounds?

RossJG

New member
Nov 13, 2012
13
0
0
Visit site
All the side buttons (power, volume, camera) just stopped working on my phone today. I'm using double-tap to wake as a workaround for power, and I can get in to the camera app without the dedicated button. Is there any way to manipulate volume without the hardware buttons? And is there any hope I could repair or resolve the button problem?

Thanks,
Ross
 

Sunil Patil2

New member
Sep 7, 2014
33
0
0
Visit site
Two things you need to check.
1. Whether the buttons won't work for any operations, apart from lock/unlock. If you can take screenshots, or if you can restart the phone using same buttons, then its software issue , and not hardware issue.
2. If you find out its sw issue., then check which app you installed recently. Try to uninstall and soft reset. If you are lucky, your mobile should be working fine.
 

RossJG

New member
Nov 13, 2012
13
0
0
Visit site
At this point I can tell you it is definitely not a software issue. I've even let the battery run down so I could get it powered off. The power button does not power the phone on when it's powered down, or have any effect. Only attaching it to power will make it boot up. I did try uninstalling recent app installs as you suggested, predictably with no effect. The volume buttons do not work at all either, and neither does the camera button. Power+vol down when the phone is on does not have any effect, as you would suspect.

What I really need to know is:
1) Is there any way for me to manipulate volume at this point in WP 8.1?
2) Is there any way I can repair this?
 

Daniel Ivascu

New member
Nov 9, 2014
6
0
0
Visit site
Disassemble it. only 2 screws, then there a metal plate covering two ribbons, one for the buttons, the other one for the micro-usb port. I think that the ribbon responsable with the buttons came out. Good luck! :D
 

RossJG

New member
Nov 13, 2012
13
0
0
Visit site
That was my thought too! But I took it apart yesterday and everything looks fine with the ribbon cable. I even took it off and reattached it onto the board, but it did not resolve the issue.

I'm really wondering what the best workarounds are for the physical side keys. So far I know these workarounds:

Replacement for:
Power button(for waking phone): Double-tap to wake
Power button(for locking/putting phone to sleep): "Touch lock" app live tile on home screen
Power button hold down(for rebooting): I have no workaround yet. The free apps I tested don't work on 8.1.
Camera button: Put the camera app on the home screen
Volume buttons(for volume adjustment): Play music, lock phone, then touch the drop-down for on-screen sliders for adjustment.
 
Last edited:

RossJG

New member
Nov 13, 2012
13
0
0
Visit site
I found the ribbon cable (with the buttons) on Amazon for $5 and ordered. We'll see how that goes. Not sure if my problem is actually on the ribbon cable or the logic board side.
 

charlie Pong

New member
May 31, 2015
1
0
0
Visit site
Any concrete solution to this problem? i received mine lumia 920 refurbish on an 8.0 OS, but after upgrading to 8.1 all buttons stop working. it was happening gradually. first the camera button then the up volume button, finally the down volume and power button within few weeks. all are off, no responds even when trying soft reset. is the problem really hardware. since it was happening in phases. it looks like this is a software issue. any help on how to fix it. I don't want to continue using tricks to use the phone. i just want to get it back it original design and usage. please help out
 

Staff online

Members online

Forum statistics

Threads
324,233
Messages
2,245,206
Members
428,179
Latest member
joshi