Bluetooth Malfunctions after Mango Update

nicknc

New member
Oct 19, 2011
3
0
0
Visit site
I have a Focus v. 1.3

Since forcing my update to Mango, I have encountered serious issues with Bluetooth.

Put simply, each time I want to connect a Bluetooth device to my phone, I have to:

1. Delete the pair from the phone
2. Reboot the phone
3. Reboot the device
4. Re-pair the device to the phone

The Bluetooth device will then work until I turn off Bluetooth on the phone, or power down the device, or walk out of range. After that, I have to repeat the above mentioned process to reconnect.

I primarily use a pair of Motorola S305 Bluetooth stereo headphones, which worked nearly flawlessly with NoDo. However, I have the behavior with other Bluetooth headsets as well.

I was able to successfully connect/disconnect the S305s from my wife's android phone without issue, exactly as the process should work.

Any advice?
 

nicknc

New member
Oct 19, 2011
3
0
0
Visit site
Okay, so just noticed this:

- If it turn on my wifi, I can connect with Bluetooth devices fine, in a completely normal fashion (without having to go through the unpair/repair steps listed above)

- If wifi is off, I cannot connect to any Bluetooth devices (without following the steps mentioned above), but any devices that had an active connection before disabling wifi will continue to work as long as I do not disconnect them

- The Data connection does not have any effect whatsoever

I'm connecting/disconnecting to Bluetooth through the default mechanism (not using any shortcut tiles, etc).

Guys, is the Bluetooth "connect" switch tied to the wifi toggle somehow?
 
Last edited:

Members online

Forum statistics

Threads
322,406
Messages
2,241,960
Members
427,920
Latest member
ohlawd