Can I get some help with MMS issues on my Nokia Lumia 900?

Jude Cross

New member
Feb 5, 2015
Visit site
Nokia Lumia 900 MMS Issues

My previous phone was a ZTE Avail 2 from AT&T. Eventually, when Straight Talk began their 'bring your own phone' deal, I switched to them.

Now I have a new phone. It's a Nokia Lumia 900 (AT&T carrier), just got it today. I know that switching phones requires setting up new APNs to use data, so I called Straight Talk to let them talk me through settings up the new phone.

After a long while, they were unable to properly direct me as to how the MMS APN settings menu is even located, let alone how to set it up. They were telling me to open menus that don't exist on my phone or tap options that did not appear on the lists.

So now I am frustrated and my phone can't send or receive picture messages. While the data does work, it's just the MMS that isn't functioning. I've searched the internet to no avail and I'm really looking for some help, here.

If you can help, please do so. It will be greatly appreciated. Thank you.


New member
Nov 12, 2012
Visit site
Yeah... There is a trick to Straight Talk MMS.

AT&T style SIM, yes?

Unfortunately I am not up on the menu trees for WP 7.x... Your MMS settings should be right in the area where you found APN. On WP 8.x it is Settings > cellular + SIM > SIM settings > edit MMS APN (your path may differ).

So for ST on an ATT style SIM, the trick is that "WAP gateway (URL)" has to be translated from a http style address to an IP address format.

MMS settings need to be:
"APN" tfdata
"User Name" <leave blank>
"Password" <leave blank>
"Authentication Type" should be set to PAP
"WAP gateway (URL)" must be
"WAP gateway port" 80
"MMSC port" 80
"Maximum MMS size" <leave blank>
"IP type" IPv4v6

Hope this helps...

Members online

Forum statistics

Latest member