Charging Issue

Durahl

New member
Apr 5, 2014
47
0
0
Visit site
Greetings!
*
Im having a charging issue with my HP Elite X3.

For the past few days I've been limited to charging it either using the provided HP Elite X3 Dock or an ancient Nokia DT-900 Wireless Charging Plate.
Attempts in charging it via the provided HP USB-C Cable on either of my many PCs USB Ports or the provided HP Traveler Charger won't charge it.
Apparently it also won't connect to a PC either - As someone over at the HP Forums mentioned.

Using a different USB-C Cable didn't work either.

The only other thing that DID work was the Dock's extension cable ( connected to the Dock )
Phone is on 10.0.15063.414

Any ideas what is going on?
 

realwarder

New member
Dec 31, 2012
3,689
0
0
Visit site
Sounds like lower voltage power connections don't work, as a PC uses 5V USB and the dock charger likely 12V+..

Could be an OS, firmware or hardware issue. I guess you could use WDRT to put the OS back and see if that changes anything in case an OS update broke things.

I would call HP or post more on their forums as you'll likely get more specialist knowledge there.
 

Durahl

New member
Apr 5, 2014
47
0
0
Visit site
I was able to solve it by joining the Insider Release Preview Build which installed an update for ARM based Phones ( Ehh... wut? ).
Very odd behavior if I may say so but hey... Beggars can't be choosers and I'm glad I'm not featuring a broken piece of hardware.
 

Members online

Forum statistics

Threads
324,208
Messages
2,245,150
Members
428,176
Latest member
Arthur Dent