How do I fix Lumia 525 hanging/freezing in WP8.1?

Satish Dhondale

New member
May 3, 2014
17
0
0
Visit site
Hello,

I was using Lumia 525 from Jan - 2014 to Aug-2014 which was running on Windows Phone 8 OS, it never get hanged or there was no lagging. Then I bought new Lumia 630 which had WP 8.1. But Lumia 525 is still in use but now its updated to WP 8.1.

After this update, the phone is getting hanged at minimum 3-4 times per month. Then I had to restart the phone. And even Lumia 630 is also getting hanged, & many times the apps doesn't get opened. It just says "Opening..." after 5 sec it gets terminated.

What is the reason for this lagging? Is this issue from Microsoft? Is this common issue for all WP 8.1 phones?
 

s2mikey

New member
Aug 16, 2014
40
0
0
Visit site
I wouldnt say its a common issue but some people have had problems. Did you try doing a full reboot of the phone? Did you install any other software or apps that might be causign trouble? Does it only happen with certain apps or the phone in general?
 

Ashish Gupta888

Retired Ambassador
Mar 12, 2014
1,303
0
0
Visit site
I think it has something to do with the SD card. Your SD card needs a system scan. You can do so by a soft reset(Power+Volume down key for 15 sec). Once phone restarts, it will ask your permission to scan SD card (if issue is with SD card) and let it scan.It should resolve the issue.
 

Satish Dhondale

New member
May 3, 2014
17
0
0
Visit site
I wouldnt say its a common issue but some people have had problems. Did you try doing a full reboot of the phone? Did you install any other software or apps that might be causign trouble? Does it only happen with certain apps or the phone in general?

The problem is same for even system apps too. From past 1 month I was using GT Racing game app but suddenly stopped working so thought to reinstall but still its not working. The app is not getting opened.
 

Satish Dhondale

New member
May 3, 2014
17
0
0
Visit site
I think it has something to do with the SD card. Your SD card needs a system scan. You can do so by a soft reset(Power+Volume down key for 15 sec). Once phone restarts, it will ask your permission to scan SD card (if issue is with SD card) and let it scan.It should resolve the issue.

I did soft reset but it did not ask for any permission to scan SD card n even it did not scan.
 

Members online

Forum statistics

Threads
322,521
Messages
2,242,170
Members
427,939
Latest member
svengollie