• Welcome to the all-new Windows Central Forums! - We're still moving some things around, so you may see a few quirks here and there, but we're working on getting things fully completed as soon as possible. For now, take a look around, and if you run into any major issues, please let us know in this thread!

I have lost Access to my C Drive, and cannot change permissions

  • Thread starter Windows Central Question
  • Start date

Windows Central Question

I have lost access to my C:\ and the control editor on my computer. When I try to change the advanced security settings of my C:\, it says click continue to attempt the operation with administrative permissions, when I do this the window freezes there is a very long delay followed by the message: Can't open access control editor: Access is denied. Please help me

B Matthews

New member
Oct 15, 2016
I've looked over the internet for the past few weeks and tried a lot of solutions similar to this one but I haven't had any success. I'm running W10, on a desktop computer I had build from PC specialist, I've had this problem for about 2 months.

In the solution you posted I was able to follow it up until the point I needed to disable UAC, specifically at :

B.Under User Account and Family settings click on the "Add or remove user account".

Where despite following all of the previous steps I still did not have access


New member
Oct 2, 2016
Hi! It's better if you start your own thread!:wink: Have you tried a in-place repair upgrade. Here's link!
The repair of Windows 10, can resolve many problems in Windows 10 functionality and some times is the most reliable and quickest way to fix the Windows 10 malfunctions. Also the in-place Windows 10 upgrade, which performed with the repair process, ensures that Windows 10 have the latest updates and fixes installed.
How to repair Windows 10 with in-place upgrade. - wintips.org - Windows Tips & How-tos

Members online

Forum statistics

Latest member