Lumia 1520.3 cannot upgrade to windows phone 8.1 and cannot use LTE

Win Luck

New member
Jun 2, 2014
20
0
0
Visit site
I received a Nokia 1520.3 that was swapped by Nokia service center yesterday. My old model was Nokia RM-938_Ita_Ita_905 which work fine expect white dots; the new model is Nokia RM-938_nam_canada_104.

The first thing I notice is that my new phone doesn't recognize the T-Mobile LTE, in the Setting, the maximum connection speed is only 3G which I used getting LTE. I also exchanged the SIM card in the T-Mobile store, still the same.

Another thing is, cannot update to Windows phone 8.1. I tried Hard reset, soft reset, use the Nokia Recovery Tool... still cannot get windows phone 8.1 update.

Please let me know your suggestions.

Thank you.
 

plot_almighty

New member
Apr 11, 2014
202
0
0
Visit site
Don't know what to tell you about the data settings except to look up APNs. As far as getting 8.1, I suggest getting a free App Studio account with your primary email and signing up for Preview for Developers. You get the same OS updates OEMs do with none of the carrier BS.

The Preview is an app you can download and is Microsoft's way of getting direct OTA updates to your phone.
 

metalchick719

New member
Oct 4, 2012
2,353
1
0
Visit site
Hmm... Access Point should set everything up for you. I assume you're on T-Mobile US since you have a 1520.3? I don't get it. If it's a Canadian (Rogers?) version, it should easily connect to T-Mobile's LTE. Hope you're able to get it all sorted out soon.
 

Kez0

New member
Aug 23, 2013
21
0
1
Visit site
Change the rom, your rom has 4g (LTE) connection disabled. About the 8.1 is because your rom is for an mobile operator that not has enabled the update for update via OTA.
 

Win Luck

New member
Jun 2, 2014
20
0
0
Visit site
I use T-Mobile US, when I turn on this phone I need to choose either T-Mobile or MetroPCS at very beginning which I never experienced in previous phone.
 

Win Luck

New member
Jun 2, 2014
20
0
0
Visit site
Hi Kez0, I did some research after read your post. It seems like someone changed the ROM and messed up the system then send the phone back to Nokia service center for repair, and Nokia just send this to me. According to some posts said if change different ROM with different code that will mess the LTE and cannot restore the LTE even flash back the original ROM. That make sense.

However, I still cannot find any answer about the "Update to 8.1" issue. I will try to install the preview as you suggest. Hope I can install the preview.
 
Last edited:

theefman

Active member
Nov 14, 2008
3,979
5
38
Visit site
Hey Kez0, according your answer, I should just switch the ROM to the 1520.3 Latin America version, right?

Thanks theefman.

You're on the right track but you have to be careful with flashing roms as there's always a risk. The Xda forums would be a good place to start, try here [Tutorial] Unbrand (flash) Nokia Windows Pho… | Windows Phone 8 Development and Hacking | XDA Forums

And this is the main forum Windows Phone 8 General - XDA Forums. Its a good idea to search and also ask questions if you're unsure about anything. Hope it works out ok.
 

Members online

No members online now.

Forum statistics

Threads
323,093
Messages
2,243,240
Members
428,023
Latest member
Badnam_Munni