My Application which is in Start up folder is not running

Rajesh Ramtere

New member
Aug 9, 2016
3
0
0
Visit site
My application which is in Startup folder is not started after restarting the computer. I find some solutions on internet like
1. Hkey_Local_Machine\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\ System\ Set EnableLUA to 0 (See at right side - By Default it is set to 1)
2. Set User Access Control settings to lowest level

When i do this settings, my application which is in start up folder, application runs when machine restarts every time.. But this setting inhibit the operation of some MS programs like MS-Edge, Photo-Viewer, Skype Video etc. Resetting to default "1" and restart PC would resolved it. We need to look for better solution to this "security measure" by later Windows version.. Please guide me with better solution
 

TechFreak1

Moderator
May 15, 2013
4,625
18
38
Visit site
Okay first and foremost is the application you are having an issue with is - Edge or a different one entirely?

If the latter, what is the application called?

Also have you tried uninstalling via control panel and reinstalling it again?
 

Rajesh Ramtere

New member
Aug 9, 2016
3
0
0
Visit site
Let me put up my problem in a different way:

1. My team has developed a windows (C# WPF) application. This application requires elevated privileges to execute. (right click on app --> "Run as administrator" even for an administrator user). This application need to run at startup occasionally (depending on user preferences).

2. When user selects to run the application on windows startup, the application creates its shortcut in the "startup folder" of the windows.

3. As this application needs administrative privileges to start running, we have made the setting as shown in the attachment image.

Problem : With this UAC settings my application startup automatically whenever configured to start, at boot on windows 7. For windows 10 (I upgraded my PC from windows 7 to windows 10 Pro recently) these settings do not help. When I right click "Run as administrator" on my application from the shortcut in the startup folder, my application works fine.

I made the registry settings as discussed earlier, It helps start the application on boot. However, some MS tools give an message saying : eg "MS Edge can't be opened using the built-in Administrator account. Sign in with a different account and try again.".



I feel, somehow the UAC prompt, which generally occurs on running this application cannot allow same application in startup mode. How can I tell windows to run the application in administrator mode ? (windows does not by default run an app in administrator mode even when logged-in user is an administrator of that PC).

UAC.PNG
 

TechFreak1

Moderator
May 15, 2013
4,625
18
38
Visit site
Let me put up my problem in a different way:

1. My team has developed a windows (C# WPF) application. This application requires elevated privileges to execute. (right click on app --> "Run as administrator" even for an administrator user). This application need to run at startup occasionally (depending on user preferences).

2. When user selects to run the application on windows startup, the application creates its shortcut in the "startup folder" of the windows.

3. As this application needs administrative privileges to start running, we have made the setting as shown in the attachment image.

Problem : With this UAC settings my application startup automatically whenever configured to start, at boot on windows 7. For windows 10 (I upgraded my PC from windows 7 to windows 10 Pro recently) these settings do not help. When I right click "Run as administrator" on my application from the shortcut in the startup folder, my application works fine.

I made the registry settings as discussed earlier, It helps start the application on boot. However, some MS tools give an message saying : eg "MS Edge can't be opened using the built-in Administrator account. Sign in with a different account and try again.".



I feel, somehow the UAC prompt, which generally occurs on running this application cannot allow same application in startup mode. How can I tell windows to run the application in administrator mode ? (windows does not by default run an app in administrator mode even when logged-in user is an administrator of that PC).

View attachment 129283

What about group policy settings?

Have you tried creating a global script in conjunction with a background service? (Set to automatic - delay)

The easiest route I see is to create a background service as forcing the application to run with the built-in administrator account is a no go as that could potentially could open up exploit holes.
 
Last edited:

Members online

No members online now.

Forum statistics

Threads
324,502
Messages
2,245,636
Members
428,215
Latest member
Josubanush