• Welcome to the all-new Windows Central Forums! - We're still moving some things around, so you may see a few quirks here and there, but we're working on getting things fully completed as soon as possible. For now, take a look around, and if you run into any major issues, please let us know in this thread!

Need Help: SP3 + Docking station, and 4k Dell Monitor

rdubmu

New member
May 25, 2011
3,314
0
0
Hello All,

I bought the docking station bundle on thanksgiving (online). It arrived today and I can not figure out how to set it up to have two screens.

Any help or assistance would be much appreciated. I have looked on line, downloaded drivers and still can't figure it out. Yes all wires are connected. :(
 

strollin

New member
Jun 23, 2014
40
0
0
You should be able to plug 1 monitor into the DisplayPort on the dock and another into the DisplayPort on the SP3. If the monitors have output DisplayPorts, you may be able to daisy chain them where 1 monitor connects to the dock and the other monitor connects to the first monitor.
 

enthuz

New member
Oct 8, 2012
411
0
0
Also in other threads and forums, some monitors required setting changes on the monitors themselves before they would pass the signal through.
 

strollin

New member
Jun 23, 2014
40
0
0
Can you offer any more details other than it won't work? Have you tried plugging the monitor directly into the SP3's DisplayPort while in the dock or out? Have you tried the monitor and cable on another computer to ensure they are both good?
 

rdubmu

New member
May 25, 2011
3,314
0
0
Hi Strollin,

My dell monitor came with Display port cable. I have tried both the cable into the docking station as well as directly into my SP3. It still doesn't work. I am thinking it might be a driver issue. I downloaded the correct driver from Dell's website and also the Dell Display manager and the manager says there is no monitor connected. I have ensured both sides of the cable (from the monitor to the SP3.Dockingstation are plugged in directly. Wasn't sure if there is a solution. There could be a few things.

1. I might be doing something wrong.
2. The cable is bad
3. The monitor could be bad
4. I don't think it is the docking station or the SP3 as the DP cable doesn't work on both.
 

strollin

New member
Jun 23, 2014
40
0
0
Do you have another system you could plug the cable and monitor into so that you can confirm that they both are good? If you can confirm that they work on another system, that narrows down where the problem is.

Since you say the Dell Display Manager doesn't even detect that a monitor is attached, I would highly suspect the cable or the monitor itself.
 

rdubmu

New member
May 25, 2011
3,314
0
0
I am so sorry for not responding fast, I used to be so active. I apparently didn't see I plugged it into the DP out, not in. It is working correctly now and I got to say this monitor is great!
 

Ask The Community

Members online

Forum statistics

Threads
315,752
Messages
2,238,386
Members
427,208
Latest member
linlu