Processor power management windows 8.1?

Moiz Mian

New member
Aug 5, 2013
824
0
0
Visit site
Anyone with a surface pro running 8.1 able to change the minimum and max processor state? For some reason I can't find that setting. I just noticed my processor is running at the full 1.7ghz. The modification really helped my battery life before
 

Moiz Mian

New member
Aug 5, 2013
824
0
0
Visit site
Well. i can go into the battery power profiles from the system tray, and then i can view advanced options, but when i click porcessor power management, i only see the option for system cooling policy. The min/max setting is gone!
 

juan6996

New member
Jul 6, 2012
341
0
0
Visit site
Go to the desktop control panel. Then search "power options". Then click on your enabled power plan and change advanced settings. Then click "change settings that are currently unavailable" then click on processor power management, and finally choose the max level for battery and or plugged in. I have mine set to 20% max, but it doesn't feel slow at all.
 

Moiz Mian

New member
Aug 5, 2013
824
0
0
Visit site
Go to the desktop control panel. Then search "power options". Then click on your enabled power plan and change advanced settings. Then click "change settings that are currently unavailable" then click on processor power management, and finally choose the max level for battery and or plugged in. I have mine set to 20% max, but it doesn't feel slow at all.

I've checked there. it's still not there
 

Attachments

  • Screenshot.jpg
    Screenshot.jpg
    219.9 KB · Views: 11

chezm

New member
Apr 9, 2013
1,364
0
0
Visit site
Go to the desktop control panel. Then search "power options". Then click on your enabled power plan and change advanced settings. Then click "change settings that are currently unavailable" then click on processor power management, and finally choose the max level for battery and or plugged in. I have mine set to 20% max, but it doesn't feel slow at all.

works on my Pro 2, excellent thanks!! Just adjusted to try out 50% max. Good suggestion
 

Moiz Mian

New member
Aug 5, 2013
824
0
0
Visit site
Ughh, yea I had done this a long time ago, and my battery life went up by like 50%. Now the setting is gone. And from what I can tell under task manager. It's not downclocking. So something weird is going on for me
 

ERFrizki

New member
Aug 15, 2013
2
0
0
Visit site
it just recently happened to me too.
i can't control minimum/maximum processor speed unlike before.

i wonder why is this happening...
 

Moiz Mian

New member
Aug 5, 2013
824
0
0
Visit site
it just recently happened to me too.
i can't control minimum/maximum processor speed unlike before.

i wonder why is this happening...

I figured it out, it's a bad registry setting or something that broke it. I did a refresh which brought it back. Unfortunately it downgraded me to 8.0 and then i had to update to 8.1. In the process I lost all my installed apps :'( All files were still intact though
 

garak0410

New member
Jan 8, 2009
985
0
0
Visit site
I've never had this option...ever. Refreshed, got a 256GB Model (passed my 128 model down), no setting and even after 8.1, still not there.
 

Moiz Mian

New member
Aug 5, 2013
824
0
0
Visit site
I've never had this option...ever. Refreshed, got a 256GB Model (passed my 128 model down), no setting and even after 8.1, still not there.

That's odd. Yea, i dunno what's up with the setting and why it randomly dissapears/appears for certain people. But do you have a 256 SP2? If so, don't worry about it! Your battery is already better than anything we can achieve with SP1 settings haha
 

garak0410

New member
Jan 8, 2009
985
0
0
Visit site
That's odd. Yea, i dunno what's up with the setting and why it randomly dissapears/appears for certain people. But do you have a 256 SP2? If so, don't worry about it! Your battery is already better than anything we can achieve with SP1 settings haha

I've got the original Surface Pro (not 2) with 256GB...they still offer them on the Microsoft Store. :)
 

jywang

New member
Nov 11, 2012
39
0
0
Visit site
The processor min and max is disabled if you have Hyper-V turned on. Hyper-V is automatically turned on if you install Visual Studio 2013 with Windows Phone SDK.

With Hyper-V on, the CPU is always running at full speed. I removed Hyper-V using Add/Remove features and my CPU is back running at slower speed.

John
 

Moiz Mian

New member
Aug 5, 2013
824
0
0
Visit site
The processor min and max is disabled if you have Hyper-V turned on. Hyper-V is automatically turned on if you install Visual Studio 2013 with Windows Phone SDK.

With Hyper-V on, the CPU is always running at full speed. I removed Hyper-V using Add/Remove features and my CPU is back running at slower speed.

John

I don't have it anymore, but in case I want to download VS 2013 with WP SDK, can I turn off hyperV and still use VS?
 

jhoff80

New member
Apr 27, 2003
1,415
0
0
Visit site
The processor min and max is disabled if you have Hyper-V turned on. Hyper-V is automatically turned on if you install Visual Studio 2013 with Windows Phone SDK.

With Hyper-V on, the CPU is always running at full speed. I removed Hyper-V using Add/Remove features and my CPU is back running at slower speed.

Again, as I said in your other thread, I think you're incorrect here. It's a reporting issue, not that the CPU is constantly at max speed.
 

Moiz Mian

New member
Aug 5, 2013
824
0
0
Visit site
Again, as I said in your other thread, I think you're incorrect here. It's a reporting issue, not that the CPU is constantly at max speed.

I don't think so, when I noticed that I lost my min/max setting, i know for sure that the last time I changed it was to 75%. After I noticed that the setting was gone, I checked task manager, and saw the CPU was hovering around 1.2-1.7ghz. Now that I have the setting back to 75%, it idles at 0.78Ghz.
 

fosormic

New member
Nov 9, 2010
1
0
0
Visit site
The processor min and max is disabled if you have Hyper-V turned on. Hyper-V is automatically turned on if you install Visual Studio 2013 with Windows Phone SDK.

With Hyper-V on, the CPU is always running at full speed. I removed Hyper-V using Add/Remove features and my CPU is back running at slower speed.

John

Disabling Hyper-V did the trick for me, thanks John. Yes you can use VS without Hyper-V but you will not be able to use the device emulators (Windows Phone or Windows RT emulation).

I agree that Performance Explorer does show an incorrect CPU speed and that CPU-Z is more accurate. After having "uncovered" this setting, I throttled my cpu to 75% max and CPU-Z keeps reporting as usual, but now Performance Explorer shows the CPU at 70% or so - constant. So, at least its inaccuracy is constant.
 

Derausgewanderte

New member
Dec 18, 2011
1,544
0
0
Visit site
Last edited:

Members online

Forum statistics

Threads
323,206
Messages
2,243,455
Members
428,045
Latest member
Ridhwan