SP4 Lagging

Steveborough

New member
May 29, 2014
49
0
0
Visit site
Anyone else experiencing this: While CPU is at nominal utilization I often experience significant lag doing mundane things like:
  • typing into Cortana, keystrokes are delayed by 3 or so seconds
  • Launching a new tab in edge takes 5 seconds
  • the cursor moves in slomo when moving around the screen
  • My favorite game, Asphalt 8 is unplayable due to significant frame drops and control lag
  • Launching Task Manager is the equivalent of launching Photoshop on an 486 and consumes 40% CPU for 25 seconds

Nothing has changed other than updates on my i5 8GB RAM, I thought the days of reinstalling the OS on your computer every 4 months was over! My SP4 is running like pure crap right now! Mainly wondering if a recent update may have bonked my system.

Update:
seems to be a problem with Cortana that many others are also experiencing, killing the "Cortana" process (automatically restarts) seems to fix it for a while.
 
Last edited:

michail71

New member
Nov 29, 2012
1,822
0
0
Visit site
I see some of these things periodically. Sometimes keyboard lag happens.

Most issues are usually Edge acting up but usually it's nice and fast.
 

anon(5327127)

New member
May 25, 2011
585
0
0
Visit site
"reinstalling the OS on your computer every 4 months was over! My SP4 is running like pure crap right now! "

It is. How do we know what you've installed? Chrome, iTunes, other software?! Each time you venture towards Cortana it will go online so how fast is your connection? There's SO many possibilities as to why.
 

CrownedMartyr

New member
Jul 29, 2014
21
0
0
Visit site
I have been experiencing the same exact thing for the past week or so. Certain activities seem fine, but others like opening emails in Outlook or even typing in Notepad are extremely slow, with very low CPU utilization. I've tried disabling all non-Microsoft services and programs at boot which did not resolve the issue. Booting to Safe Mode did, however.

It's bad enough that I may try reinstalling Windows.
 

mclark2112

New member
Feb 8, 2005
93
0
0
Visit site
Same thing here, frequent slowdowns or freezes. Seems that OneNote and Outlook are always involved. I have the i7 16gb RAM Surface, this is a recent thing. Must be a bad update to something.
 

CrownedMartyr

New member
Jul 29, 2014
21
0
0
Visit site
Just out of curiosity - does anyone have any Egnyte products installed? I discovered that it was Egynte Drive that was causing my performance issues. Uninstalling the software fixed this for me.
 

CraigCole

New member
Nov 5, 2015
193
0
0
Visit site
Edge makes my SP4 grind to a halt. If I have Facebook open in a tab for more than 30 minutes it's deadly; ditto for Tweet Deck. Something about this browser just sucks the system's resources.
 

Steveborough

New member
May 29, 2014
49
0
0
Visit site
150Mbs symmetrical, only windows store apps plus Office 2016, PhotoShop CC and Traktor 2; resident programs, just OneDrive and Defender... such a sh!tshow...its like owning a moody cat!
 

Members online

No members online now.

Forum statistics

Threads
324,653
Messages
2,245,834
Members
428,222
Latest member
Lucasmorth