TUT:Install FULL WP8 SDK on Windows 7

khader_moham

New member
Aug 27, 2013
174
0
0
Visit site
If you'd like the Mini SDK(works on all versions of windows 7,8) Check this post
http://forums.windowscentral.com/wi...et-wp-8-sdk-mini-windows-7-a.html#post2282329
You can Register you phone and Sideload apps only

AS OF NOW IT ONLY WORKS ON WINDOWS 7 X64
To install the SDK, perform the following:

1. Download the Windows Phone 8 SDK iso file. You can get it at http://go.microsoft.com/fwlink/?LinkID=257234&clcid=0x409
2. extract the contents of the ISO to the location of your choosing.
3. Download the modified "WPexpress_full.exe" from here http://dl-1.va.us.xda-developers.co....zip?key=AtehfX4oyFEALmhOKpZkLA&ts=1442009994 and use it to replace the one in the iso.
4. install visual studio
5.run setup as normal.

Everything will install and work.
if you get an error launching the "Application Deployment" app update Visual Studio 2012 to Update 3

Source :Tutorial: Install Windows Phone 8 SDK on Windows 7 the Easy Way - xda-developers
 
Last edited:

hopmedic

Active member
Apr 27, 2011
5,231
0
36
Visit site
Before I dig into this.... I want to install it on my PC at work, where I have Win7 x64, so it sounds like it will work. But I have Visual Studio 2013 Professional installed already. I'm wondering if this is going to just install the express version alongside my current environment, or if it might cause any problems. Or, will this install the SDK right into my existing environment? If you have answers, I'd love to hear them before I dive in.

Thanks!

EDIT: Just realized it is VS 2012 that the installer adds, but I have VS 2012 Professional installed on my PC as well. So still wondering if it would install alongside, or if it would install into my existing environments.

Thanks again!
 

hopmedic

Active member
Apr 27, 2011
5,231
0
36
Visit site
Ok, I've answered my own questions. Impatience has paid off.

First, on my Win7 x64 machine with VS 2008, 2010, 2012, and 2013 installed, following this procedure did NOT install a VS 2012 Express instance next to my existing environments. The WP8 templates are all there in VS 2012, and at the moment I'm waiting for VS 2013 to launch, but it's taking a while. I may need to reboot my machine, but I'm not going to do that now because I get off work in about 20 minutes, and it takes at least 10 minutes for this dumb machine to boot up, with all the bloatware the bank puts on it to be sure I don't copy any files onto a jump drive.....

Wait! VS 2013 just started. Now it's telling me it is prerelease software and the license is expired. I swear I installed the RC over the preview, when the RC came out.... I guess tomorrow I'll be uninstalling and reinstalling VS2013... Grrr.....
 

benihognogi

New member
Sep 17, 2014
1
0
0
Visit site
DUDE! You are my favorite kind of people on the internet. By describing your experience saved me a lot of work, since I'm in a similar situation. I owe you a few beers, and keep up the good work.
 

Michael Ogbe

New member
Feb 7, 2015
1
0
0
Visit site
Hi, Thanks for the Information, kindly assist am having the following error when trying to create a new project after successfully installing the WP8 SDK on Windows 7:

System.NullReferenceException
Object reference not set to an instance of an object.
 

vipresh

New member
Aug 18, 2013
31
0
0
Visit site
After Installing the SDK Lite version on my Windows 7 PC - 64 bit , I am not able to debug Web Apps in VS2013 ..
I tried repairing VS2013 - didn't work.
Tried Uninstalling VS2013 and Reinstalling - didn't work.
Tried Uninstalling VS2013, .NetFramework4.51 and 4.5 and then Re-Install VS203- didn't work.

Any idea what changes are made the SDK Lite version that doesn't allow Debugging Web Projects?
By Debugging I mean , when I try to Run the Web App , CS2013 starts IIS express the Web site tries to connect on the port but then fails and debugging stops without giving any error.
 

vipresh

New member
Aug 18, 2013
31
0
0
Visit site
After Installing the SDK Lite version on my Windows 7 PC - 64 bit , I am not able to debug Web Apps in VS2013 ..
I tried repairing VS2013 - didn't work.
Tried Uninstalling VS2013 and Reinstalling - didn't work.
Tried Uninstalling VS2013, .NetFramework4.51 and 4.5 and then Re-Install VS203- didn't work.

Any idea what changes are made the SDK Lite version that doesn't allow Debugging Web Projects?
By Debugging I mean , when I try to Run the Web App , CS2013 starts IIS express the Web site tries to connect on the port but then fails and debugging stops without giving any error.
 

Members online

Forum statistics

Threads
322,445
Messages
2,242,018
Members
427,926
Latest member
loepoez