Why has my touch screen been acting strange since replacing the screen (Lumia 1520)?

  • Thread starter Windows Central Question
  • Start date
W

Windows Central Question

Strange screen not responding: Lumia 1520

Hey

I bought a Lumia 1520, and I have so far been very happy with it.
I recently dropped it and broke the screen. Everything worked perfectly, but it was hard to read anything on it.
My brother replaced the touch screen (which was hell because of all the glue), and it worked for a while.

The thing now is:
I turn it on and the screen works perfectly for about 2 mins, then it completely stops working.
After I soft reset it, it works for another 2 mins.
I have also tried to hard reset it.

Does anyone here have a clue what is happening, and if it is possible to fix it without ordering a completely new front side?

Thanks!
 

Harrie-S

Retired Ambassador
Sep 26, 2014
5,378
0
0
Visit site
Re: Strange screen not responding: Lumia 1520

Sorry but what happens is clear. The repair failed.
Did you get an original OEM part for the replacement?
If not than that may be the reason if yes then you damaged something during the repair.
So if you did not use an original OEM part try it again with a original part.
 

RumoredNow

New member
Nov 12, 2012
18,134
0
0
Visit site
Re: Strange screen not responding: Lumia 1520

Also, separating the digitizer from the glass and reattaching a new one is prone to error... Get the whole assembly. And as Harrie says, make sure it is OEM for 100% compatibility not only hardware-wise, but with the firmware as well.
 

Peter Skinnes

New member
Feb 7, 2015
1
0
0
Visit site
Re: Strange screen not responding: Lumia 1520

Thank you for your replies.
The part was not OEM, but bought from Ebay.
The reason I ask was because it seems strange to me that it works for 2 mins after every restart.
In my head, this means the screen is working, but some minor issue happens during those 2 mins.

I guess I will have to buy a new front part to get it to work.
 

Harrie-S

Retired Ambassador
Sep 26, 2014
5,378
0
0
Visit site
Thank you for your replies.
The part was not OEM, but bought from Ebay.
The reason I ask was because it seems strange to me that it works for 2 mins after every restart.
In my head, this means the screen is working, but some minor issue happens during those 2 mins.

I guess I will have to buy a new front part to get it to work.

Welcome to WC Peter,

Sorry for the bad news we had to bring.
And all the work you or your brother put in the repair.
But we saw already a lot of issues with non OEM parts.
And the price difference makes it hard to resist to buy a "compatible with" spare part.
 
Last edited:

Members online

No members online now.

Forum statistics

Threads
322,381
Messages
2,241,914
Members
427,918
Latest member
cameronbosch