Windows 10 Mobile build 14965 Discussion (Redstone 2; Slow Ring)

James Clarkson

New member
Dec 9, 2016
10
0
0
Visit site
I am on the slow ring with the 950xl and this build is the worst insider build I have ever used. It is worse than the ones earlier this spring.

It has frequent screen locks which either fix themselves, require a soft reset, or, 6 times now, removing the battery. These happen on any app and along with the fact the phone slows down and starts forgetting apps quicker the longer it is on points to memory leaks being the culprit.

It has broken some apps that haven't even been updated since before this build. For example, mytube audio playback is broken now and it hasnt been updated since the beginning of November. The build also occasionally puts an installed app as pending and has it stick like that for hours forcing you to uninstall it and reinstall to actually use it.

I know this is the kind of thing that comes with an insider preview program but I went from a phone that would only restart when a phone update happened to one that requires two a day or it will force one anyway and am quite irritated at both this and the appearance of talking to a wall in the feedback app.
 

Mark F24

New member
Oct 12, 2014
410
0
0
Visit site
Then don't be on the slow or fast ring. Never a good idea to use your daily device in Windows insider when it comes to using one phone or if you need functions to work at all times. Get a second windows phone to do all the testing you heart desires. I have a Lumia 640 for testing out the fast ring. I don't use my Lumia 950 for OS testing. Especially when I need my phone to work in case I get a txt for meetings an such. Or anything important. Or a call. That just my two cents. No offense intended to anyone. :)

I have a 950DS and a 950XL DS and usually don't run the same release on both at the same time, but I find that the device without the sim card and not being used full time usually runs great. Having the phone fully functional brings out faults that you wouldn't experience otherwise and this I can say with a lot of experience.
 

James Clarkson

New member
Dec 9, 2016
10
0
0
Visit site
I know that and I do have an old device for fast ring testing (a 2 year old 830) though this issue never came up on that phone probably for the lack of use as well. I also have a cheap phone at home just for calls and texts.

I'm just complaining about this build which is the reason for this thread. Anyway, this is the first slow ring build of Redstone 2 anyway so issues are both expected and shouldn't persist that long.
 

wgrs

New member
Jun 9, 2014
246
0
0
Visit site
The build also occasionally puts an installed app as pending and has it stick like that for hours forcing you to uninstall it and reinstall to actually use it.

I had this too and I found the reason:

When I installed the new build, after reboot my "SD card was broken, need repair". This is an old nonsense since WP8: the SD card is perfect which I tested with a computer.

But WM10 needs to "repair" the SD card which results in a 30 minutes file system check. In the meanwhile, all apps which are supposed to be on SD card, get upgraded to internal memory. After the SD card comes back, Windows thinks the app should be on SD card, but in reality is internal. Then the whole thing is "pending" forever. Because their "clever" programmers did not think about that.

You have to delete the app and reinstall. No other solution.

With all such cr*p, I came to the insight that apps on SD cards are evil. Windows just cannot handle it, even if it should not be any problem. I moved most apps now internal, and only keep those apps on SD cards which seem to work well and not cause problems. These are mostly apps which I don't use often.
I'm still testing, but I believe the cr*p with "live tiles not updating" is also connected with apps on SD card.
 

James Clarkson

New member
Dec 9, 2016
10
0
0
Visit site
Intermittent no wifi, no Wallet, the wifi is a deal breaker for me.

I do not use wallet, I don't even really know what to use it for either.

But WiFi, as far as I can tell it only happens on some routers. I go to some of my friends houses and WiFi craps out every 10 minutes, but at mine its never been a problem at all. I also only use 5GHz at home, 2.4 GHz is full of Bell routers. Would using only 5GHz possibly help?
 

wgrs

New member
Jun 9, 2014
246
0
0
Visit site
I rarely have wifi problems. Never at home, and very occasionally with trashy hotel routers and such. Wifi connectivity with my Lumia is actually better than with the iPad.
 

James Clarkson

New member
Dec 9, 2016
10
0
0
Visit site
I had this too and I found the reason:
SNIP.

Sorry about the double post, I couldn't figure out how to multiquote in a single post. I tried and it just ate the first draft of this.

All the apps that pending thing happened to were on internal storage and one of them was MyTube which does not install on a sd card. Sd card apps were fine. It was just one internal app got corrupted or something and had to be reinstalled.

It hasn't happened again, but I'm also manually restarting my phone more to avoid hard locks so maybe its because of that locking issue.
 

Captain_Eric

Member
Dec 31, 2007
476
0
16
Visit site
I do not use wallet, I don't even really know what to use it for either.

But WiFi, as far as I can tell it only happens on some routers. I go to some of my friends houses and WiFi craps out every 10 minutes, but at mine its never been a problem at all. I also only use 5GHz at home, 2.4 GHz is full of Bell routers. Would using only 5GHz possibly help?

I have the same problem, meaning the wifi is sometimes just fine, and other times it's terrible, resetting every 10-20 minutes. The problem is intermittent, so hard to figure out.

Maybe it is the 2.4GHz vs.5GHz, I really don't know that much about wifi frequencies.
 

James Clarkson

New member
Dec 9, 2016
10
0
0
Visit site
I just had this happen to me a couple times.

When listening to music over headphones, I unplugged the cable to go do something and when I plugged the headphones back in and tried to play music again it refused to play anything and I had to restart the phone. However before i restarted the phone audio worked without headphones plugged in. I tried to recreate it with everything I knew I had opened, but it didn't work. Has this happened to anyone else?
 

Joe920

Active member
Nov 13, 2012
1,677
0
36
Visit site
Yesterday I hit power to unlock, but then without unlocking I pressed the camera button instead, to take a picture. The picture came out OK, but 20 seconds later the phone rebooted. Pretty scary that such bugs still happen on the Slow Ring.

As an aside, it would be nice if this thread could be made sticky ..
 

Joe920

Active member
Nov 13, 2012
1,677
0
36
Visit site
Another day, another failed shutdown. Again my 950XL got stuck on 'Goodbye' for minutes. Anyone else getting this?

[thanks for the sticky, whoever finally did it!]
 
Last edited:

James Clarkson

New member
Dec 9, 2016
10
0
0
Visit site
Just a FYI that might prevent someone some grief.

I had an installed app on internal storage go pending again and since it was the weekend, I decided to wait to see if it fixes itself.c Last night it did fix itself and broke everything else.

Once I enter an app, navigation bar stops working, power button stops working. This happens on all apps that open, some can't get through the loading screen, and it still happens even after I uninstalled that app. So if that happens, uninstall immediately, it'll save you some grief.
 

Joe920

Active member
Nov 13, 2012
1,677
0
36
Visit site
Yesterday I hit power to unlock, but then without unlocking I pressed the camera button instead, to take a picture. The picture came out OK, but 20 seconds later the phone rebooted.
Well, something's not right with the camera app and/or this build on the 950XL. Yesterday I took two pictures and put my phone in my pocket. A bit later I noticed the hot-pocket effect, took out the burning hot phone which had the screen on, saying 'your device rebooted' or something. How on earth does a camera app/photos app cause an entire device reboot? On the 'slow ring' no less.. :angry:
 

Ryujingt3

New member
Nov 13, 2013
3,310
1
0
Visit site
How is Groove and battery life on the latest Slow ring build? I left the Insider program a while back (now on Production) but, I am thinking about rejoining but I need Groove to work to play my music from my SD card and decent battery life too. I get both of these with the Production build so will I get the same from the Slow ring?
 

speccy

New member
May 9, 2013
595
0
0
Visit site
Had a problem with calls today, couldn't hear the person at the other end regardless of where they were calling from. Reboot solved it but still...
 

Dano91

New member
Oct 17, 2015
102
0
0
Visit site
How is Groove and battery life on the latest Slow ring build? I left the Insider program a while back (now on Production) but, I am thinking about rejoining but I need Groove to work to play my music from my SD card and decent battery life too. I get both of these with the Production build so will I get the same from the Slow ring?

I don't know about Groove, but battery life on my L650 is definitely better than it was on Production ring! True, I'm not using my phone that heavy, but still, I'm running 3rd day and 20% is still remaining.

EDIT: Actually, I'm now looking at the battery stats and I had 41% battery before I went to sleep and after exactly 8 hours it dropped to 39%, which means 0.25%/h of battery usage. That surely is my new record, cause previously on production builds I averaged ~0.7%/h while not using phone. (Yes, I always have battery saver turn on right from 100%)

OTOH, I have a problem with Glance screen. It's just not working at all while battery saver is activated. When deactivated, everything is back normal. Can anybody please confirm this? If so, I will appreciate your vote on Feedback Hub, I already reported this bug, here's the link: https://aka.ms/Riqc48
 
Last edited:

locolyric

New member
Jun 23, 2015
14
0
0
Visit site
there is no glance screen when battery saver is activated. is not a bug at all.But it can be add in as a feature.
How does everything work in battery saving mode? any delay for all apps?
 

Dano91

New member
Oct 17, 2015
102
0
0
Visit site
there is no glance screen when battery saver is activated. is not a bug at all.But it can be add in as a feature.
How does everything work in battery saving mode? any delay for all apps?

Well, the way it behaves is buggy - you enter the "Glance screen" settings > turn the main switch on (additional settings should show up, but they will not) > you go back to previous page (personalization) > again you enter glance settings > miraculously the switch is in off position by itself.

Battery saver has no effect on performance, it only blocks background tasks. Then in Battery settings you can manage app exceptions to this rule.
 

Members online

No members online now.

Forum statistics

Threads
323,697
Messages
2,244,237
Members
428,102
Latest member
Korshun