WPCentral.com, Surface RT, IE10 Metro (Metro, Metro, Metro) crashing the browser

Jeffrey Fox

New member
Jun 5, 2013
140
0
0
Visit site
So I've been trying to view the WPCentral website on my Surface RT running the standard IE10 browser and lately its been crashing fairly consistently. After going to the site it first becomes unresponsive, not loading the entire homepage, showing the loading dots (you know the ones, at the bottom of the screen in IE10) and after a minute of frantically swiping around the screen and/or clicking on links to try to get past the homepage and into the forums the browser crashes and reloads. This is only happening with the WPCentral website on my Surface RT so I figured I'd start asking here to see if there is a known issue going on lately.

I'm currently on my desktop PC running Windows 8 and IE10 and everything is peachy keen, trying it on my Surface RT and its crashing now. Hralp me!
 

stmav

Retired Moderator
Sep 18, 2012
3,684
0
0
Visit site
I've been fighting the same problem for a while. It is usable if you use the desktop internet explorer.
 

DBDev

New member
Jan 13, 2012
2,380
0
0
Visit site
Ok, lets start with device, OS version, browser version... also, is your browser running in 'compatibility mode' or anything like that?

It is a 32GB Surface RT and the browser is ie10. Here's a screenshot of the about page from the browser in desktop mode. No, I don't use capability mode, but I use some TPL if that can have something to do with it.
 

Jeffrey Fox

New member
Jun 5, 2013
140
0
0
Visit site
I also have the Surface RT 32gig model. IE10 in "Metro" mode, no compatibility modes or anything similar.

https://skydrive.live.com/pagenotfounderror

It looks like I'm running the same version of IE10 as DBDev.

Here's an example of my problem. After I posted this thread I tried browsing around a little bit. It starts out just loading very slowly, like the site can't keep up with me scrolling down (https://skydrive.live.com/pagenotfounderror). At this point hyperlinks are dead, I can't click anywhere but I can scroll around for a little while longer. Eventually it just freezes completely, although I can still pull the tab down and close the page (https://skydrive.live.com/pagenotfounderror)

Hope this helps.
 

spyderzWPC

New member
Sep 14, 2012
270
0
0
Visit site
I had bing crashing my IE 10 desktop browser on my win 8 64, thing that fixed it was a fresh build. I do love the restore options on windows 8 they work great. I would suggest uninstalling the IE app and reinstalling it from the store, or check your error logs see if anything sticks out.
 

stmav

Retired Moderator
Sep 18, 2012
3,684
0
0
Visit site
I did that on my Surface yesterday as well. And for the first time in a long time, I was able to use the metro IE for normal use plus other tasks with no freeze ups or problems. Will report back in a couple of days, hopefully that it's still going strong.
 

Members online

Forum statistics

Threads
323,206
Messages
2,243,455
Members
428,044
Latest member
fixitnow