X3 battery issues

enzom09

New member
May 8, 2013
38
0
0
Visit site
So I got my x3 from the MS store (in person) on Thursday (it's now Sunday) and after getting all the updates and stuff, I'm a little disappointed in the battery life/charge time. I struggle making it through the day and apparently the biggest resource hog is edge and I don't even use it that frequently. I thought usb-c would support quick charge but this phone does not charge anywhere near to 80% in 30min like the 950 does with the provided charger. Oh well, love the phone, reminds me of a better version of my 1520, minus the pretty yellow color. Any suggestions out there? Fingerprint/iris scanner be hurting me a lot?
 

Lumious

New member
Jun 16, 2015
550
0
0
Visit site
So I got my x3 from the MS store (in person) on Thursday (it's now Sunday) and after getting all the updates and stuff, I'm a little disappointed in the battery life/charge time. I struggle making it through the day and apparently the biggest resource hog is edge and I don't even use it that frequently. I thought usb-c would support quick charge but this phone does not charge anywhere near to 80% in 30min like the 950 does with the provided charger. Oh well, love the phone, reminds me of a better version of my 1520, minus the pretty yellow color. Any suggestions out there? Fingerprint/iris scanner be hurting me a lot?

80% in 30 min?? lol, I wish I had your phone. My 950 XL, to no surprise isn't any faster than a standard Samsung fast charger with my Note 5 or 650 with micro usb. I get around 55-70% per hour, which translates to about 27-35% in 30 minutes. No where near the claimed over half a charge in less than 30 minutes in the keynote last year and your claim.

And not that I doubt your battery life but it contradicts directly to what Dan Rubino has been saying all along on twitter and various other podcasts. He gets unheard of battery life. It is probably something to do with firmware updates or the way you are using it/background apps.
 

Ariel Takom

New member
Aug 9, 2015
386
0
0
Visit site
80% in 30 min?? lol, I wish I had your phone. My 950 XL, to no surprise isn't any faster than a standard Samsung fast charger with my Note 5 or 650 with micro usb. I get around 55-70% per hour, which translates to about 27-35% in 30 minutes. No where near the claimed over half a charge in less than 30 minutes in the keynote last year and your claim.

And not that I doubt your battery life but it contradicts directly to what Dan Rubino has been saying all along on twitter and various other podcasts. He gets unheard of battery life. It is probably something to do with firmware updates or the way you are using it/background apps.

with my 950, I actually do get about that much of charge. Not 50% exactly, but about 45-47% I guess?
 

mrmobileperformance

New member
Mar 2, 2016
47
0
0
Visit site
So I got my x3 from the MS store (in person) on Thursday (it's now Sunday) and after getting all the updates and stuff, I'm a little disappointed in the battery life/charge time. I struggle making it through the day and apparently the biggest resource hog is edge and I don't even use it that frequently. I thought usb-c would support quick charge but this phone does not charge anywhere near to 80% in 30min like the 950 does with the provided charger. Oh well, love the phone, reminds me of a better version of my 1520, minus the pretty yellow color. Any suggestions out there? Fingerprint/iris scanner be hurting me a lot?

You might have a bad unit. Since the firmware update the battery life on my X3 has been awesome.

Sent from mTalk
 

TechFreak1

Moderator
May 15, 2013
4,625
18
38
Visit site
Hmm, if it is indeed edge the only way to know is stop it running in the background. Go to Battery in settings -> Battery -> Battery usage by app -> Scroll to Microsoft Edge -> From Managed by Windows put it to never allowed in the background. Run it a few days and to see if battery life improves.

Also try turning off the sync for bookmarks and passwords off if you don't use em.
 

Daniel Rubino

Editor-in-chief
Staff member
Jan 19, 2006
1,039
26
48
Visit site
Standard WP issue, have this on my lumia 730 since WP8.1 and now on W10m.

I wouldn't call this standard as in it does not happen at all for me on a few devices, nor should it for the OP. Quite literally there could be something wrong with their card and they should consider wiping it and re-copying the data to it.

So I got my x3 from the MS store (in person) on Thursday (it's now Sunday) and after getting all the updates and stuff, I'm a little disappointed in the battery life/charge time. I struggle making it through the day and apparently the biggest resource hog is edge and I don't even use it that frequently. I thought usb-c would support quick charge but this phone does not charge anywhere near to 80% in 30min like the 950 does with the provided charger. Oh well, love the phone, reminds me of a better version of my 1520, minus the pretty yellow color. Any suggestions out there? Fingerprint/iris scanner be hurting me a lot?

I'm quite certain it supports fast charge. But it's a 4,150 mAh battery vs. the ~3000 on the 950. I'm not a 100% certain, but I think the % rate is somewhat proportional to battery size. I just couldn't imagine if there was a 20,000mAh battery would it pull 10,000 mAh in 30 minutes? Probably not.

As far as general battery life, Zac and I have had a very good experience and this phone by far gets the most battery life of any WP device we have used. Having said that, I noticed that battery life did go down with the FW update, which makes sense since the CPU is now operating at a full capacity with the OS. It's still amazing, just not as amazing as before when there was some lag/choppy graphics.

As far as Edge, that is easy. Go into Battery settings and list by app; disable Edge and any other program you don't want running in the background. Could help.
 

techiez

Member
Nov 3, 2012
832
0
16
Visit site
I wouldn't call this standard as in it does not happen at all for me on a few devices, nor should it for the OP. Quite literally there could be something wrong with their card and they should consider wiping it and re-copying the data to it.

Well the forums of WC n MS have a lot of posts on this, so cant blame on the cards.
 

enzom09

New member
May 8, 2013
38
0
0
Visit site
Is anyone having an issues or seen any reported issues with texting. If I lose service for greater than 5min (happens all the time at work) I can't send out sms. It just says try again. Mms works, internet works, phone calls work. Just sms doesn't work. Got a new sim from tmo and still the same issue. Any ideas?
 

Members online

Forum statistics

Threads
324,668
Messages
2,245,852
Members
428,219
Latest member
Lucasmorth