05-20-2016 09:03 AM
2,234 ... 1213141516 ...
tools
  1. ajayden's Avatar
    Hey Everyone,

    So today I finally decided to install Windows 10 TP and here are my reviews.

    As of now all the apps are working pretty welll. Camera, Photos, Outlook, Calender, Messaging. Even though a bit slow but atleast all of these are working.

    The only issue I am having is, I am unable to switch ON the mobile data. Any solution for that other than hard reset?
    No solution
    04-15-2015 11:48 AM
  2. shobhit92bhar's Avatar
    No solution
    Even hard reset will not help?
    04-15-2015 11:52 AM
  3. hotphil's Avatar
    Also There are like two apps I purchased does the Microsoft Store work like the Apple Store where if I payed for it once I should be able to get it back?
    Should do. But there does seem to be some issues for some folks syncing purchase history. Especially if they **** about with region settings etc to try and get Cortana (who'd have thunk changing region would screw up region-specific Store purchases?)
    Let your new install settle for aa couple of hours before judging performance as all sorts of background sync/indexing etc will be trying to sort itself out. A good time to explore all the new settings menus.
    04-15-2015 11:54 AM
  4. NVMY03ION's Avatar
    Okay so Im back online.. One of the bugs Im seeing if if I get a noticiation that I click on a new email. The calendar launches. Anyone else seen this? So far things seem better.. Atleast the KB is working better
    04-15-2015 11:59 AM
  5. Ashish Gupta888's Avatar
    Okay so Im back online.. One of the bugs Im seeing if if I get a noticiation that I click on a new email. The calendar launches. Anyone else seen this? So far things seem better.. Atleast the KB is working better
    It's a known bug in this build. They should fix it in the next build, I assume.
    04-15-2015 12:02 PM
  6. NVMY03ION's Avatar
    It's a known bug in this build. They should fix it in the next build, I assume.
    Drats - Sorry to be repetitive but Im not reading through 14 pages of documents LOL!!!! How fast have they been on updates?
    04-15-2015 12:05 PM
  7. NVMY03ION's Avatar
    Furthermore is there a way to break out the inboxes So you don't have to go into Outlook and change between accounts?
    04-15-2015 12:05 PM
  8. hotphil's Avatar
    Last week's preview build was the second in three months I believe.
    Past performance being no indication of the future etc.
    04-15-2015 12:07 PM
  9. hotphil's Avatar
    Furthermore is there a way to break out the inboxes So you don't have to go into Outlook and change between accounts?
    Not yet.
    04-15-2015 12:07 PM
  10. ajayden's Avatar
    Even hard reset will not help?
    A hard reset did it for my phone. So you can try.
    04-15-2015 12:39 PM
  11. Ashish Gupta888's Avatar
    Has anyone obesrved that battery charging rate is too damn slow? I plugged in to charge it and it just increased 2% in 30 minutes!!
    Also, battery discharges quickly than expected (yesterday it went to 0 from 7% in 1 minute).
    I am planning to downgrade it to 8.1 now, battery life sucks with W10 TP, but I'll miss notifcation center ;-)
    Last edited by Ashish Gupta888; 04-15-2015 at 02:45 PM.
    04-15-2015 01:58 PM
  12. shobhit92bhar's Avatar
    A hard reset did it for my phone. So you can try.
    Are you unable to enable/disable it now? I mean both?
    04-15-2015 02:16 PM
  13. ajayden's Avatar
    Are you unable to enable/disable it now? I mean both?
    Yes
    04-15-2015 08:12 PM
  14. mnsiw's Avatar
    On Lumia 535, hard reset solved the data problem.
    04-15-2015 11:32 PM
  15. hotphil's Avatar
    Has anyone obesrved that battery charging rate is too damn slow? I plugged in to charge it and it just increased 2% in 30 minutes!!
    Also, battery discharges quickly than expected (yesterday it went to 0 from 7% in 1 minute).
    I am planning to downgrade it to 8.1 now, battery life sucks with W10 TP, but I'll miss notifcation center ;-)
    I've never put faith in indicated battery life. Especially for the first few cycles of a new OS install.
    I know some people get all "OMG it says 22.785221% left, but I put it down for 3mins 4 secs and now it only says 22.76123% left!!! What's going on? Is it broken? It's unacceptable? How can that be right?"
    And the simple explanation is, it isn't right.
    Indicating battery percentage has always been inaccurate. I don't see it changing anytime soon.
    Putting reliance on those figures may be misleading.
    04-15-2015 11:48 PM
  16. prem2530's Avatar
    I too have faced the same issue with lot of other issues like SIM card not detecting, like that. Finally a hard reset helped me. Now my phone is charging and discharging normally like before.
    04-15-2015 11:55 PM
  17. AaronMark017's Avatar
    My phone app stopped working ! so the phone was completely useless. very laggy. at the beginning but eventually it worked nice. couldn't add google account in outlook. maps didn't work at all. app loading time is much longer. And I hated the dialer ! Battery performance was similar......switched back to 8.1 , and happy now.
    LUMIA 822
    04-16-2015 12:04 AM
  18. Ashish Gupta888's Avatar
    I've never put faith in indicated battery life. Especially for the first few cycles of a new OS install.
    I know some people get all "OMG it says 22.785221% left, but I put it down for 3mins 4 secs and now it only says 22.76123% left!!! What's going on? Is it broken? It's unacceptable? How can that be right?"
    And the simple explanation is, it isn't right.
    Indicating battery percentage has always been inaccurate. I don't see it changing anytime soon.
    Putting reliance on those figures may be misleading.

    It was pretty accurate in 8.1. Last night it took 4 hours to get charged to 48% from 20%..Weird, isn't that? Battery life has suddenly become very poor with this build of TP.
    04-16-2015 01:36 AM
  19. hotphil's Avatar
    It was pretty accurate in 8.1. Last night it took 4 hours to get charged to 48% from 20%..Weird, isn't that? Battery life has suddenly become very poor with this build of TP.
    You've installed the TP and got through several battery cycles since last night?
    04-16-2015 01:53 AM
  20. Ashish Gupta888's Avatar
    You've installed the TP and got through several battery cycles since last night?

    Nope. I am using since day 1 of TP release (build 2). It was working fine for first few days but starting Tuesday, battery drains too quickly and charging rate has become ultra slow.
    04-16-2015 02:28 AM
  21. Wikus Kruger's Avatar
    Howsit guys

    Using L920, all working quite well, i dont have alot of issues, only one thing, incoming calls not linking to my phonebook, so i cannot identify incoming calls, any fix or workaround for this?
    04-16-2015 05:32 AM
  22. NVMY03ION's Avatar
    SO - So Far so good on the fresh install. It does seem much more responsive. Do I need to reinstall the Insider in order to get updates on the build or does the native Updater take over on that front?

    Also - What happened to the "GLANCE" Feature? I like my phone screen to turn off at night. I have my quiet hours enabled but I notice when I use to be able to glance I don't see it illuminate anymore
    04-16-2015 06:02 AM
  23. hotphil's Avatar
    I reckon you'll need to reinstall the Insider app if you want to receive any new builds via that method.
    NVMY03ION likes this.
    04-16-2015 06:23 AM
  24. prabu d's Avatar
    Even hard reset will not help?
    I had same issue. Hard reset worked for me.
    04-16-2015 08:00 AM
  25. Ickis99's Avatar
    Using L920, all working quite well, i dont have alot of issues, only one thing, incoming calls not linking to my phonebook, so i cannot identify incoming calls, any fix or workaround for this?
    Contact linking works on my L920, but i made a hard reset since my SIM was not recognized so maybe thats the solution?

    By the way, are there any news if there are any smaller bugfixing builds planned for the fast ring or do we have to wait another 2 months for the next one?
    04-16-2015 10:00 AM
2,234 ... 1213141516 ...

Similar Threads

  1. [WM10] Lumia 1520 Bugs & Defects
    By ahsan_aa in forum Nokia Lumia 1520
    Replies: 39
    Last Post: 01-22-2017, 11:12 AM
  2. Long term review of 640XL-W10M- Dumped Note 4
    By ak_r7 in forum Microsoft Lumia 640 XL
    Replies: 2
    Last Post: 03-31-2016, 10:07 AM
  3. Has a non insider version of wp10 been released?
    By djeire84 in forum Windows 10 Mobile
    Replies: 2
    Last Post: 03-30-2016, 07:56 PM
  4. Windows Phone Notification Bug?
    By DotNetRob in forum Windows 10 Mobile
    Replies: 0
    Last Post: 03-29-2016, 12:14 PM
  5. Reply to the message threads in notification bar?
    By Windows Central Question in forum Windows 10
    Replies: 0
    Last Post: 03-29-2016, 09:12 AM
LINK TO POST COPIED TO CLIPBOARD