1. Elvis7's Avatar
    Since installing build 586.63 on my lumia 1920, the phone has been clunky and battery never lasts more than 6 hours.

    The phone only works well with mobile data turned off.

    After looking into it, system uses 65% of the battery life. And system has used 961MB of mobile data in the past 6 days, and 4gigs in the past 30 days.

    What the hell is going? Ive already hard reseted the phone on new builds and do a soft reset every morning. I doubt Microsoft will look into my issue and pay my freaken phone bill.

    How do I stop "system" from causing all these issues without having data off 24/7

    Help please.
    01-22-2016 12:16 AM
  2. Chintan Gohel's Avatar
    Since installing build 586.63 on my lumia 1920, the phone has been clunky and battery never lasts more than 6 hours.

    The phone only works well with mobile data turned off.

    After looking into it, system uses 65% of the battery life. And system has used 961MB of mobile data in the past 6 days, and 4gigs in the past 30 days.

    What the hell is going? Ive already hard reseted the phone on new builds and do a soft reset every morning. I doubt Microsoft will look into my issue and pay my freaken phone bill.

    How do I stop "system" from causing all these issues without having data off 24/7

    Help please.
    Your store is updating apps automatically. Disable that in store settings
    Which apps can run in background? Such as skype. They might be consuming a lot of data and battery life. Disable store also
    System is all core apps such as messaging, store, phone, contacts, skype, etc.
    01-22-2016 12:33 AM
  3. ajayden's Avatar
    Since installing build 586.63 on my lumia 1920, the phone has been clunky and battery never lasts more than 6 hours.

    The phone only works well with mobile data turned off.

    After looking into it, system uses 65% of the battery life. And system has used 961MB of mobile data in the past 6 days, and 4gigs in the past 30 days.

    What the hell is going? Ive already hard reseted the phone on new builds and do a soft reset every morning. I doubt Microsoft will look into my issue and pay my freaken phone bill.

    How do I stop "system" from causing all these issues without having data off 24/7

    Help please.
    Lol. Nice hoping that Microsoft will pay your bill.

    You should revert back to W8.1 and wait until WM10 is released for older phones.
    01-22-2016 12:46 AM
  4. Maurizio Troso's Avatar
    Lol. Nice hoping that Microsoft will pay your bill.

    You should revert back to W8.1 and wait until WM10 is released for older phones.
    Come on, there's a settings for limiting data usage!!!
    01-22-2016 02:38 AM
  5. Maurizio Troso's Avatar
    Since installing build 586.63 on my lumia 1920, the phone has been clunky and battery never lasts more than 6 hours.

    The phone only works well with mobile data turned off.

    After looking into it, system uses 65% of the battery life. And system has used 961MB of mobile data in the past 6 days, and 4gigs in the past 30 days.

    What the hell is going? Ive already hard reseted the phone on new builds and do a soft reset every morning. I doubt Microsoft will look into my issue and pay my freaken phone bill.

    How do I stop "system" from causing all these issues without having data off 24/7

    Help please.
    Enable data usage limit in settings. Phone will wait for a wifi signal for updates, and will notify it
    01-22-2016 02:46 AM
  6. Elvis7's Avatar
    Setting is enabled for limiting data. Store does wait for wifi to update. Someone just posted a reference to the sync between all devices option killing battery life and data.. Ill disable it and try it out today. No wonder the messaging app is second place for data and battery usage.
    01-22-2016 03:54 AM
  7. DavidinCT's Avatar
    Disable store also
    System is all core apps such as messaging, store, phone, contacts, skype, etc.
    Just wondering on this one, by disabling CORE app does this disable Notifications for new emails, texts etc ? I have a Microsoft band 2 (yea, blue-tooth does take a hit on battery) but, I depend on email notifications.

    Even on my ICON, I'll see 8-9 hours, by 7pm on a work day, my battery is beeping (less than 10%), on 8.1 with a band 1 (same features), I would still have 50%+ left by 7pm....

    It's one thing that sucks about W10m preview... battery....
    01-22-2016 08:43 AM

Similar Threads

  1. Windows hello issues
    By Sfairat in forum Microsoft Lumia 950 XL
    Replies: 9
    Last Post: 03-12-2016, 04:30 PM
  2. Bluetooth issue with 10586.63 build
    By Dr.Nitun in forum Windows 10 Mobile Insider Preview
    Replies: 10
    Last Post: 01-30-2016, 05:55 PM
  3. Lumia 530 touch issue, what could it be?
    By Windows Central Question in forum Microsoft Lumia 530
    Replies: 0
    Last Post: 01-21-2016, 03:27 AM
  4. How can I fix a wifi connectivity issue on my Lumia 730?
    By Windows Central Question in forum Nokia Lumia 730 & 735
    Replies: 0
    Last Post: 01-20-2016, 06:44 AM
LINK TO POST COPIED TO CLIPBOARD