The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
03-07-2015 03:13 PM
106 1234 ...
tools
  1. Wam1q's Avatar
    Same issue with my 1020 with Cyan, too. The screen doesn't dim and the navigation button lights don't turn off even with Battery Saver brightness turned on. The biggest advantage of battery saver (dining the screen) is no more there. The screen stays very bright and still consumes a lot of battery. :(
    11-04-2014 08:06 AM
  2. volpenger's Avatar
    It was working until some days ago....
    11-04-2014 08:51 AM
  3. Wam1q's Avatar
    It was working until some days ago....
    Same for me... It was working a few days ago.
    11-04-2014 10:33 AM
  4. AC_44's Avatar
    I just got the 8.1 Cyan update on my Lumia 925 yesterday, and I've had this problem ever since. The Battery Saver app seems to recognize when the battery gets to that low point, but it doesn't dim the screen at all.

    I wonder if through making the Battery Saver a separate app Windows has created a disconnect between the app itself and the "Battery Saver Brightness" setting (since the latter appears under Display settings rather than within the app itself) and that's why it doesn't function properly anymore? Whatever the issue is, it really needs to be fixed because the Battery Saver is practically useless now when the battery life gets low...
    11-04-2014 05:30 PM
  5. volpenger's Avatar
    Just thinking about the issue... is it related with whatsapp?? before the update it was working well...
    11-05-2014 08:18 AM
  6. furkanavshar's Avatar
    Just thinking about the issue... is it related with whatsapp?? before the update it was working well...
    No. I'm fighting against this issue on my and my family's Lumias for 5 months. My father doesn't have WhatsApp, so...
    This is related with Battery Saver and Display updates, after Cyan.
    I reset my phone, everything go well; but when I update the Battery Saver and Display update together, it's starting to crash again. If I don't update one of them, this works fine.
    Last edited by furkanavshar; 11-06-2014 at 08:41 PM.
    11-06-2014 04:50 PM
  7. volpenger's Avatar
    Intresting, thanks for sharing this info!
    Sent from my drone upon your head.
    11-07-2014 04:11 AM
  8. DenniSundaY's Avatar
    Same problem here with my 930, when battery saver is on, my touch keys still light up and the screen is still pretty bright too! I am on WP 8.1 update 1 and Lumia cyan. Maybe Denim will resolve it...
    11-07-2014 10:18 AM
  9. volpenger's Avatar
    Hard reset done, display and battery saver not updated. All works correctly. Let's see in the future if the issue occurs again.
    P.s. The new version of whatsapp saves all the conversations after hard reset even in devices without sd card. Good news, indeed.
    sent from my drone upon your head
    11-10-2014 12:57 PM
  10. volpenger's Avatar
    Issue is here,again! Battery saver and dispaly app are not guilty....
    last updated app were device hub, call+sms filter and nokia feedback...
    11-11-2014 03:56 AM
  11. furkanavshar's Avatar
    I confirmed.

    Resolving of this issue:

    1) Reset your phone
    2) Never open "Device Hub" in Settings
    3) Set the date like 2150 or more
    4) Go to Settings and tab "Device Hub"
    5) This will ask you "Uninstall"
    6) Tab "Uninstall"
    7) Set the date "auto" again

    Don't install "Device Hub"
    OK! This issue will never come over again!
    Last edited by furkanavshar; 11-11-2014 at 09:28 AM.
    11-11-2014 09:07 AM
  12. volpenger's Avatar
    Yes, it was working until I've opened device hub Nokia feedback and call+SMS. Let's hope that you're right!
    sent from my drone upon your head
    11-11-2014 10:58 AM
  13. DenniSundaY's Avatar
    Recent update for device hub didn't resolve the problem either. I still think it is a firmware problem thus Denim suppose to fix it...

    Edit: Recent update of battery saver also didn't resolve the problem either. Standing by my case: DENIM WHERE ARE YOU!
    Last edited by DenniSundaY; 11-13-2014 at 04:50 AM.
    11-12-2014 10:11 AM
  14. wlupus's Avatar
    My Lumia 830 with Denim on board. But my issue is oppsite than yours: even if I switched off the battery saver the light of buttons does not appear, moreover, on my glance screen battery icon always with shield on it, like battery saver is on while it is not in real. The only way to return the light for buttons is to switch off the second thumbler from above in Display Settings (something like brigthness during battery saver mode). But shield on glance is so bothering!
    Think we need at least Emerald update to fix it without hard-reset-and-never-run-some-apps-again.
    11-13-2014 04:55 AM
  15. blkvzgo's Avatar
    Will try the Device Hub fix later today. Will Device Hub reinstall itself if I set automatic app updates to ON?
    11-13-2014 05:26 AM
  16. furkanavshar's Avatar
    Will try the Device Hub fix later today. Will Device Hub reinstall itself if I set automatic app updates to ON?
    No.
    Perform hard reset. When resetting completed, update your system apps via store. Then uninstall Device Hub. It will not reinstall itself anymore.
    11-13-2014 06:10 AM
  17. wlupus's Avatar
    Do you guys know, does it necessary to delete call+sms filter and nokia feedback for fixing that issue?
    11-13-2014 06:27 AM
  18. furkanavshar's Avatar
    Do you guys know, does it necessary to delete call+sms filter and nokia feedback for fixing that issue?
    No, not necessary. Device Hub must not be opened even once, then you need to uninstall it.
    11-13-2014 07:30 AM
  19. Z8JLsgokUI's Avatar
    Yeah. This worked for me. It totally made sense now. I installed the update and problem started. Follow your steps and it worked.
    11-13-2014 08:57 AM
  20. Z8JLsgokUI's Avatar
    Do you guys know, does it necessary to delete call+sms filter and nokia feedback for fixing that issue?
    Nope. I tried. Confirmed is the device hub
    11-13-2014 09:01 AM
  21. Windowlino's Avatar
    My Lumia 830 with Denim on board. But my issue is oppsite than yours: even if I switched off the battery saver the light of buttons does not appear, moreover, on my glance screen battery icon always with shield on it, like battery saver is on while it is not in real. The only way to return the light for buttons is to switch off the second thumbler from above in Display Settings (something like brigthness during battery saver mode). But shield on glance is so bothering!
    Same for me with Lumia 920 8.1 DP Update 2. But I kind of like the dark, invisible buttons and the darker screen :)
    11-13-2014 11:31 AM
  22. furkanavshar's Avatar
    My Lumia 830 with Denim on board. But my issue is oppsite than yours: even if I switched off the battery saver the light of buttons does not appear, moreover, on my glance screen battery icon always with shield on it, like battery saver is on while it is not in real. The only way to return the light for buttons is to switch off the second thumbler from above in Display Settings (something like brigthness during battery saver mode). But shield on glance is so bothering!
    Think we need at least Emerald update to fix it without hard-reset-and-never-run-some-apps-again.
    The solution above also will solve your opposite issue. This is confirmed too.
    11-13-2014 12:29 PM
  23. wlupus's Avatar
    I know, thank you! I am too lazy for hard reset, I want necrosoft to fix that by update or something!
    11-14-2014 12:32 AM
  24. blkvzgo's Avatar
    The device hub fix seems to have worked, but there was a catch. First I tried restoring from a back up, which for some reason failed. Then I started from a clean sheet after a hard reset and allowed all the apps to update. This didn't work, so I did another hard reset, didn't connect to my Microsoft account, disabled mobile data and didn't connect to wi-fi. I deleted device hub right after the OS loaded, only after which I proceeded with configuring the phone. So I guess you need to delete device hub first and only after that update all the apps.
    11-14-2014 12:59 AM
  25. wlupus's Avatar
    Maybe it possible to make something with device hub itself without hardreset? Is there any users, who has bouth device hub and correct battery saver mode?
    11-14-2014 04:30 AM
106 1234 ...

Similar Threads

  1. battery issues
    By Abhishek Mullick in forum Ask a Question
    Replies: 1
    Last Post: 08-17-2014, 09:01 PM
  2. How to fix: Why my hashtags are not working on instagram.
    By Greece2014 in forum Ask a Question
    Replies: 0
    Last Post: 08-17-2014, 04:02 AM
  3. Replies: 0
    Last Post: 08-17-2014, 02:55 AM
  4. Bing maps on windows phone 8.1 lumia 525 not working
    By aerosidinc in forum Ask a Question
    Replies: 0
    Last Post: 08-17-2014, 02:25 AM
  5. Tiles have stopped working
    By tezlaw in forum Nokia Lumia 1020
    Replies: 1
    Last Post: 08-16-2014, 09:00 PM
LINK TO POST COPIED TO CLIPBOARD