1. mercilesskiller's Avatar
    Hi All,

    I'm using the deskop "Windows App" connector to sync my iTunes playlist with my Lumia 920.

    I have a playlist containing the songs I want to sync though experiencing some odd behaviour. I select only that playlist, and all the songs get transferred, but it then says "syncing playlist" and the application crashes!!! everytime.

    On my phone, all the songs are there but the playlist of course isn't which is quite frustrating as I have multiple playlists I do want to sync.

    Can't find any error logs to suggest why it's crashing at this point everytime. I'm assuming there may be a corrupt file/song or some DRM or something but there's 3000 songs in the playlist. Will take a while to go through each one individually...

    Does anyone have any quick way to debug this or find the error logs?

    Thanks!
    11-14-2012 06:31 AM
  2. Tyler Huynh's Avatar
    I'm having a similar problem. I can synch several of my playlists but there is one it's choking on and crashes each time. My guess is the same, some song is giving it problems but it's going to be a pain to figure out which and why.

    iTunes doesn't have any problems with the playlist or songs.
    11-14-2012 12:58 PM
  3. mercilesskiller's Avatar
    Its to do with certain files. Windows Media Player sync tells you which song errors and you can then remove it.

    So export your playlist as .m3u, import to windows media player, use that to sync the playlist, see which songs error, remove them from itunes. Fixed.

    What a hassle
    11-14-2012 01:37 PM
  4. cmixon's Avatar
    The MS app for synching songs to the Nokia 920 crashes frequently but I have also found that any song with a bit rate higher than 256K will not play at all on the device.

    When I do a direct copy to the phone directory with a 256 or lower file, it asks if I want to convert and copy, if I select a 900 k or lossless (most of my library) it simply says will not play.

    Anybody have a workaround?
    11-14-2012 08:01 PM
  5. vedichymn's Avatar
    The MS app for synching songs to the Nokia 920 crashes frequently but I have also found that any song with a bit rate higher than 256K will not play at all on the device.

    When I do a direct copy to the phone directory with a 256 or lower file, it asks if I want to convert and copy, if I select a 900 k or lossless (most of my library) it simply says will not play.

    Anybody have a workaround?
    Which format are you using?
    11-14-2012 08:02 PM
  6. cmixon's Avatar
    In my Itunes Library they are m4a files. The 256K m4a move over fine as do any rare mp3 files I have.

    Most of my library however is Apple loss less and are 700 to 900Kbps and those bomb out every time, either with the app moving them over but they don't play or direct copy to the phone where it simply says won't work.

    Chris
    11-14-2012 08:48 PM
  7. cmixon's Avatar
    Found a solution. Downloaded Doubletwist and it recognized the 920 immediately and moved my playlist over without any issues. I don't know if the MS app is in house or licensed, but the interface for the actual music sunch in the buggy MS app looks exactly like the Doubletwist app screen.

    So if the MS app is crashing while moving playlists, try Doubletwist. It's free and seems to work great.

    Chris
    11-17-2012 11:38 AM
  8. teo155's Avatar
    My Windows Phone app (on mac) is always crashing at the startup. I tried to use doubletwist, but it seems to not recognize the phone (lumia 920) (it doesn't even appear on the sidebar); i read it's for android, so i don't understand how could it works..
    please i need help, because i can't sync songs but with skydrive (which takes longer)

    P.s. when i plug-in the phone to my mac, it makes the sound, so the cable is working with no problem!
    11-29-2012 05:28 PM
  9. vedichymn's Avatar
    My Windows Phone app (on mac) is always crashing at the startup. I tried to use doubletwist, but it seems to not recognize the phone (lumia 920) (it doesn't even appear on the sidebar); i read it's for android, so i don't understand how could it works..
    please i need help, because i can't sync songs but with skydrive (which takes longer)

    P.s. when i plug-in the phone to my mac, it makes the sound, so the cable is working with no problem!
    I suspect on a Mac you're probably out of luck with doubletwist.
    11-29-2012 05:40 PM
  10. teo155's Avatar
    I suspect on a Mac you're probably out of luck with doubletwist.
    and i'm out of luck with Windows Phone app as well! :P damn it..
    11-30-2012 03:10 AM
  11. SnailUK's Avatar
    I found a simple solution. The WP app always crashes on the song it has issues with. So just look at the progress bar, close the app & remove phone, delete/hide the track, and start again. Mine had an issue with one particular album, once removed, its worked perfectly since.

    Whats worse, is once its sync'd, if you delete a tune from your collection, it crashes trying to delete the track from the phone. I found i had to delete all music from the phone, then do the full sync again.
    11-30-2012 04:03 AM
  12. teo155's Avatar
    The problem (for me) is that the WP app crashes right when i open it, so i have no time to do anything. It's so wierd...
    11-30-2012 04:42 AM
  13. teo155's Avatar
    I finally solved my problem in this way:
    - removing the WP app with AppCleaner (for Mac)
    - removing manually the folder com.microsoft.Windows-Phone-7-Connector (which was in ~/Library/Containers/)
    - reinstalling WP app from the app store

    I think this should work for everyone; thanks for the help!
    11-30-2012 05:27 AM
  14. kevinxb's Avatar
    I was having this problem and found that when trying to sync a playlist that had multiple songs by the same artist, the ID3 tag of one of the songs had an extra space at the end of the artist's name. After removing the space in the tag, I sync'd with no crash. More detail in this thread: http://forums.windowscentral.com/win...ml#post1793466
    11-30-2012 09:53 PM
LINK TO POST COPIED TO CLIPBOARD