Time for more discounts! Shop all the best Cyber Monday deals NOW

  1. Jennifer Mitchell's Avatar
    Is there a way to correct Error Code: 80048888 without having to delete and recreate your email accounts on Nokia Lumia 920? I'm a windows smartphone power-user. I have utilized all of the 25 email accounts capacity and capabilities on my Nokia Lumia 920. It would be very disappointing to have to delete and recreate each email account. There has to be an easier solution.

    Other types of phones such as Android, Symbian, etc allow you to locate the old certificate, delete it and reinstall the new certificate without having to make you delete and recreate each email account. If the solution for windows phone is to delete and recreate each email account, the programmers need to go back to the drawing board and find a better solution. Please advise.
    Last edited by Jennifer Mitchell; 03-07-2013 at 03:32 PM.
    03-07-2013 01:44 PM
  2. jfa1's Avatar
    03-07-2013 01:53 PM
  3. Jennifer Mitchell's Avatar
    My problem with Error Code: 80048888 does not stem from Messenger. It stems from the use of SSL Certificates on my Nokia Lumia 920. If a certificate expires and then renewed, it causes an error, specifically error code 80048888 even after you try to reinstall the new and valid certificate.

    I've tried to reinstall the certificate with the application SSL Tester, it does not work. I have tried to manually install the new and valid certificate, it does not work. I'm at a loss. I didn't want to have to delete and recreate 25 email accounts on my phone which seems to be the only solution that I am finding online at this time

    There has got to be an update for the phones with an easy fix. If not, I suggest it.
    03-07-2013 03:24 PM
  4. Jennifer Mitchell's Avatar
    How can I recommend the windows phone as an enterprise phone to any company with this issue?
    ViktorG and fbloise like this.
    03-13-2013 03:28 PM
  5. cr8n's Avatar
    seriously. I have the same problem. Ridiculous. Can't wait to get my blackberry back next week.
    ViktorG likes this.
    03-14-2013 02:52 PM
  6. Huime's Avatar
    Is there a way to correct Error Code: 80048888 without having to delete and recreate your email accounts on Nokia Lumia 920? I'm a windows smartphone power-user. I have utilized all of the 25 email accounts capacity and capabilities on my Nokia Lumia 920. It would be very disappointing to have to delete and recreate each email account. There has to be an easier solution.

    Other types of phones such as Android, Symbian, etc allow you to locate the old certificate, delete it and reinstall the new certificate without having to make you delete and recreate each email account. If the solution for windows phone is to delete and recreate each email account, the programmers need to go back to the drawing board and find a better solution. Please advise.
    Isn't that deleting cert and reinstalling takes the same time and effort as to set up the a new account since you just need to retype the email and password?
    03-14-2013 07:37 PM
  7. markfive's Avatar
    I didn't want to have to delete and recreate 25 email accounts on my phone which seems to be the only solution that I am finding online at this time
    There has got to be an update for the phones with an easy fix. If not, I suggest it.
    Can you provide a little more information?

    Which version of Exchange in use? (I assume it's Exchange, a cert problem on outlook.com would be affecting lots of people)
    Are all the mail accounts you have defined on the phone accessing the same domain?
    Have the accounts worked correctly in the past?
    03-14-2013 07:51 PM
  8. mfarlow's Avatar
    I have the same problem. One of my POP3 accounts is throwing this error, and even if I delete and reinstall I get the same exact error. I'm not using SSL on this account, so I shouldn't even need a cert.

    This is a deal breaker for me if I can't access my mail on the phone.
    03-29-2013 12:15 PM
  9. Amit Dixit's Avatar
    I am getting certificate error for m.google.com.. mails are not working.. Lumia 520 with Windows 8
    04-19-2013 04:44 AM
  10. dlencastre's Avatar
    Hello,

    After a few trials, I was able to see the following issue as all of you.

    In my case, I have an internal debian mail incoming ssl att por 993 and outgoing tls att port 465

    Sending internal mail to my domain works, but sending to gmail or hotmail it fails and the problem was the error that appears to you.

    What worked for me? After I have noticed that there was no place to set the doors, and knowing that ssl993 is common, the only uncommon was tls 465, so, in the sending server after the server name I set, the door. Like this mail.exemple.org:465

    It worked.
    04-29-2013 05:12 AM
  11. smueller2749's Avatar
    Hi,

    it seems I have the same issue as described with the first post. I use a Nokia Lumia 920. Synchronizing mail stopped working two weeks ago when I changed my user account password for the company's Exchange server (yes, I updated the password on the phone). We have some other WP8 users in the company but they don't have the issues. The difference to those other users is that none of them has the Nokia Lumia 920 (they have other phones, e.g. 620) and that they did not set up the Microsoft Live Mail account when setting up the phone for the first time. I.e. they created the Live account but they did not set it up as mail account on the phone. I got the advise to set my phone back to factory defaults to get rid of the Microsoft Live mail account (as there is no other way to get rid of it, once set up... thanks for that). I don't want to do that, but I will try it soon if that is the only chance I got.

    Mail synchronization seems to work when I am not logged into wlan. But not always. Manual synchronization (clicking the sync icon while viewing the mail folder) works usually when not logged into wlan. With wlan turned on the sync worked once or twice only directly after recreating the mail account.

    I recreated the mail account several times. It did not help. I have another mail account (to a private Horde server) set up on the phone. I even deleted that account and tried recreating the company mail account. Did also not help... I was assured that the server certificate did not change since I got the phone. After creating the mail account, I am asked whether I want to accept the certificate, as it is self-signed (I confirmed this, of course). I even installed the company's root certificate on the phone (by sending it as an attachment in a mail to myself... seriously? wtf?). There seems to be no way to review installed certificates, so I cannot verify if there is really an issue with the cert (I don't think so).

    The version of the Exchange server seems to be 14.3.123.3 (I have no experience with mail server configuration and no direct access to the server).

    So I have three accounts on the phone:
    • Microsoft Live (which I cannot delete)
    • company (Exchange, with domain, that's the one not working)
    • private (Horde, different domain, deleting this account did not help)


    The company mail account did work without problems until two weeks ago, when I changed my password.

    If you (I hope there is actually someone reading this who might be involved in Nokia Lumia phone development and/or Windows Phone 8 development) have any further questions feel free to ask. I will check this thread for a couple of days, maybe weeks.

    Cheers
    07-04-2013 07:45 AM
  12. MijnLabo's Avatar
    Did some testing on this issue and I must agree: The only solution to this problem is to delete and reconfigure the email profile(s) on the phone. There's only one thing I couldn't figure out and that is: is this a Nokia Lumia (Phone 8) issue, or is this an Windows Phone 8 OS issue?
    For additional info on my testing results click Nokia Lumia Windows Phone 8 certificate error code 80048888 - mijnlabo.

    UPDATE: had some time to further investigate the problem. I've found a solution and therefore I've updated Effort #3 on my webpage devoted to the problem. I've learned that a Windows Phone 8 doesn't trust certificates signed by subordinate CA's, even when it already trusts the Root CA. In order to solve the problem make sure you install all certificates (public part) on the phone. With all certificates I mean the Root CA and all subordinate CA certificates. For detailed info, you can visit the hyperlink displayed above. Regards, mijnlabo.
    Last edited by MijnLabo; 09-10-2013 at 03:14 PM.
    09-10-2013 09:01 AM
  13. MijnLabo's Avatar
    I had some additional time to further investigate this problem, and I've found a solution for it. I hope this solution can help all of you to solve the problem on your phones too. Because of the solution I've updated my webpage devoted to this topic: Nokia Lumia Windows Phone 8 certificate error code 80048888 - mijnlabo (effort #3 is modified). A short summary: make sure you install all certificates (public part) on your phone. By all certificates I mean root and all subordinate certificates. A Windows Phone 8 don't trust certificates signed by a subordinate CA even when it trusts the root CA already. Regards, mijnlabo (mijnlabo - IT artikels - articles).
    09-10-2013 03:10 PM
  14. Antchexec's Avatar
    And what does one do when the server which has the certificate problem is blu-m.hotmail.com? This account cannot be deleted and reset, as already stated above; and obviously I do not have access to that server.

    What is also frustrating is that the error is intermittent, probably once every two or three hours over the last week. However, when the server is contactable, the phone does not continue to attempt to sync any more (or so it seems). When I go into the email (wondering why I have not got any messages for an hour or two), I get the certificate error message stating "blah, blah 47 minutes ago". When I cancel the message, my emails all come through. If the damn thing would simply try again, ignoring failures, it would be perfectly acceptable (and I would probably never know about the odd failure). As it is, I have to go into my inbox, perpetually, to ensure I am still contactable.

    This is unacceptable.
    09-27-2013 03:13 PM
  15. Antchexec's Avatar
    I'm sure others here are more sophisticated then me; and, consequently, have more complex reasons for this error. However, I thought it sensible to explain how the issue was resolved in my case, in the event it helps some that find this thread, searching for the same.

    The cause was my unfortunate decision, recently, to enable "Automatically connect to wifi hotspots", in the wireless settings. The result was that the phone would connect to random open wireless connections as I roamed the streets, but could not get an internet connection to check for email. Quite why this resulted in a certificate error I do not know. However, I do not care too much, either; and have disabled this feature and all is now well.
    Jason Jackson2 likes this.
    09-28-2013 02:03 PM
  16. Darryl Bates-Brownsword's Avatar
    thank - this was the solution for me
    12-04-2013 08:01 AM
  17. Jason Jackson2's Avatar
    I'm sure others here are more sophisticated then me; and, consequently, have more complex reasons for this error. However, I thought it sensible to explain how the issue was resolved in my case, in the event it helps some that find this thread, searching for the same.

    The cause was my unfortunate decision, recently, to enable "Automatically connect to wifi hotspots", in the wireless settings. The result was that the phone would connect to random open wireless connections as I roamed the streets, but could not get an internet connection to check for email. Quite why this resulted in a certificate error I do not know. However, I do not care too much, either; and have disabled this feature and all is now well.
    Yes mine was connected to my home WiFi broadband connection but the telephone lines had blown down so no internet connection. I disabled WiFi and bingo got onto mobile data. Problem solved. This reply should be at the top so you don't have to wade through the tech laden wrong comments above.
    02-16-2014 05:29 AM
  18. Robert Worrall's Avatar
    Just open up the Hotmail account within the phone and use the sync button that is shown.
    This will fix the problem.
    03-04-2014 04:29 AM
  19. cuek80's Avatar
    hi, dont know if the OP still need a fix. but i happen to have this issue with my 625. I go to settings-account, my microsoft account status is "attention is needed", open it, and I change the server from bay405.m.hotmail.com to m.hotmail.com and this solve the problem. can sync again etc.
    hope this works for others too.

    thanks
    03-26-2014 02:47 AM
  20. shakir azmi's Avatar
    I am getting certificate error for m.google.com.. mails are not working.. Lumia 520 with Windows 8
    07-26-2014 06:58 PM

Similar Threads

  1. How to take a screenshot on Nokia Lumia 920
    By Chris Parsons in forum Windows Phones
    Replies: 20
    Last Post: 12-16-2014, 06:56 PM
  2. Can't subsribe to podcasts on Nokia Lumia 920
    By dvdhills in forum Windows Phones
    Replies: 5
    Last Post: 03-15-2014, 08:52 PM
  3. Replies: 27
    Last Post: 05-05-2013, 06:03 PM
  4. Clove taking advanced orders on Nokia Lumia 920
    By DJ Reyes in forum Windows Phones
    Replies: 2
    Last Post: 12-02-2012, 11:57 AM
  5. Missing features and Apps on Nokia Lumia 920
    By serpentyne in forum Other Operating Systems
    Replies: 2
    Last Post: 11-19-2012, 09:39 AM
LINK TO POST COPIED TO CLIPBOARD