1. WPCentral Question's Avatar
    Hi,
    I have the BLU Win HD LTE unlocked. for some reason it doesn't show anything in device manager at all when I connect with a USB cable. The phone is charging though. I thought being a windows phone it would have better compatibility but my android devices have been better. Any idea what I can do? I wanted to transfer files
    01-17-2016 03:38 AM
  2. RumoredNow's Avatar
    Usually it is a borked driver setup.

    Use this utility: View any installed/connected USB device on your system Right click the executable and Run as Admin.

    Examine your USB drivers and delete any that look related to the BLU or Lumia (you may have some legacy drivers from either class left over that cause conflict).

    Plug the BLU in again and let the drivers install.

    FWIW I've had 2 BLU Windows Phones and never had an issue getting them recognized by 8.1 or 10. I've had far more driver conflicts that needed clearing with Android handsets, but I used to really mod the heck out of them.


    If you need to add additional information or want to post additional questions, please join the site so you can see the reply button and continue the conversation in the same thread you originally made. Please see this link for instructions on how to join Windows Central.
    01-17-2016 02:07 PM

Similar Threads

  1. De-brand your AT&T Lumia 640 LTE.
    By Meier538 in forum Microsoft Lumia 640
    Replies: 189
    Last Post: 11-07-2016, 03:09 PM
  2. When will I get Windows 10 update for my Lumia 930?
    By Windows Central Question in forum Nokia Lumia 930
    Replies: 1
    Last Post: 01-17-2016, 02:09 AM
  3. My 830 heats up.
    By Eddie Fufy in forum Ask a Question
    Replies: 1
    Last Post: 01-16-2016, 11:35 PM
  4. Replies: 0
    Last Post: 01-16-2016, 08:56 PM
  5. Why my L550 has random WIFI bugs?
    By Ouail Aouattah in forum Ask a Question
    Replies: 0
    Last Post: 01-16-2016, 07:22 PM
LINK TO POST COPIED TO CLIPBOARD