02-22-2018 07:24 AM
586 ... 89101112 ...
tools
  1. Easwaran N's Avatar
    So far after upgrading to win 10 and using it more than 24 hrs I figured out some noticeable bugs in Blu win HD LTE:

    1)Weird Battery Charging: The charging takes a long time.Even after using original factory cable and 2.1 AMP wall charger the charging is too slow.Charging speed is downgrading from 41%/hr to even 10&/hr.Don't know if this is a os issue or battery problem.

    2)Brightness Level: When I select brightness level say 14 manually.But after the phone reboots the brightness increases and goes to 20 or more.Every time I have to manually lower the brightness level. But after reboot it again increases.

    5)I can't toggle between 4g 3g or 2g. Also due to the modified firmware My LTE speed is only about 16Mb/s. I tried 3 different sim cards but the result was same.
    1 and 2 are reported by 150Q owners as well, I think.
    5 is not specific to W10. This option is not there in 8.1 also. I bought my Blu phone in Jan, but discovered this only two weeks ago. This option was there in my previous mobile - Micromax canvas win121.

    Another thing about this Blu phone - When data transfer happens, there used to be a blinking arrow over the network symbols - both cellular and wifi symbols. This is not present in the Blu Win HD LTE. Nothing serious, just an observation.
    04-10-2016 03:00 PM
  2. abhijit pore's Avatar
    1 and 2 are reported by 150Q owners as well, I think.
    5 is not specific to W10. This option is not there in 8.1 also. I bought my Blu phone in Jan, but discovered this only two weeks ago. This option was there in my previous mobile - Micromax canvas win121.

    Another thing about this Blu phone - When data transfer happens, there used to be a blinking arrow over the network symbols - both cellular and wifi symbols. This is not present in the Blu Win HD LTE. Nothing serious, just an observation.
    Yeah Thanks. I know that the toggling option was present on even my HTC Windows 8S. But before flashing this latest image i was on 15009 firmware where i used to get 55Mb/s LTE speed on my Airtel 4G Sim cards. Any way Let's wait my be Blu might release updated firmware thruogh ota.
    04-10-2016 03:31 PM
  3. ajayaacharya's Avatar
    There is no turn by turn voice navigation in the maps app on my BLU (Its there on my Lumia), the settings for the same are also missing in the app. (Considering we don't have access to HERE maps now, having no voice navigation in the in built maps app is a major drawback) If any of you have the same problem and have a work around or a solution pls let me know.
    04-10-2016 03:52 PM
  4. dudeabides's Avatar
    i am unable to download the firmware from wdrt. keeps saying error downloading package. check proxy settings. Anyone experienced the issue?
    04-10-2016 11:19 PM
  5. Easwaran N's Avatar
    There is no turn by turn voice navigation in the maps app on my BLU (Its there on my Lumia), the settings for the same are also missing in the app. (Considering we don't have access to HERE maps now, having no voice navigation in the in built maps app is a major drawback) If any of you have the same problem and have a work around or a solution pls let me know.
    I don't think this is a BLU specific issue. It is one of the draw backs of the Maps app by MS. Heard that they are improving the Maps app considering the fact that Here Maps and Drive will not be available for W10 mobile.
    04-11-2016 01:54 AM
  6. OhneZ's Avatar
    The only problem found: Back button not working in Outlook. Can anyone confirm?
    Yes i confirm this. a the moment is this the only Issue was i have found.
    04-11-2016 02:16 AM
  7. OhneZ's Avatar
    There is no turn by turn voice navigation in the maps app on my BLU (Its there on my Lumia), the settings for the same are also missing in the app. (Considering we don't have access to HERE maps now, having no voice navigation in the in built maps app is a major drawback) If any of you have the same problem and have a work around or a solution pls let me know.
    I have offline maps downloaded (menu system). After I entered the destination, several approaches have been proposed. Then I have a selected and navigation started immediately.
    04-11-2016 02:28 AM
  8. naveen4181's Avatar
    i am unable to download the firmware from wdrt. keeps saying error downloading package. check proxy settings. Anyone experienced the issue?
    Yes!I'm also facing same problem!Tried all firewall setting/tried on different OS/tried on different desktop.
    Any help guys
    04-11-2016 04:20 AM
  9. abhijit pore's Avatar
    Yes!I'm also facing same problem!Tried all firewall setting/tried on different OS/tried on different desktop.
    Any help guys
    Check this. Open WDRT then click on three dots at the right bottom side. click on settings.click on application data then click on clean all app data .click on network. Click on Use proxy server and turn on. Then in the port box put the value 8080 leave address box blank.And try to download. Make sure your pc is running on windows 8.1 or windows 10.
    04-11-2016 07:59 AM
  10. naveen4181's Avatar
    Still the same ! @abhijit
    04-11-2016 08:39 AM
  11. tushardhingra's Avatar
    Yes i confirm this. a the moment is this the only Issue was i have found.
    Same here...back button not working in Outlook mail app for exiting the app.
    04-11-2016 01:35 PM
  12. Alexunder93's Avatar
    Any chance windows will get 2G/3G/4G cellular settings? Something to force the phone into one of them would be very needed.
    abhijit pore likes this.
    04-11-2016 02:12 PM
  13. shmsnh's Avatar
    I was hoping there would be an OTA update for the firmware, because I really didn't want to go through the flashing route.

    But... I couldn't resist any longer. Currently flashing the new firmware onto my phone. Looking forward to Windows 10 Mobile.

    Thanks to everyone who figured out how to get this going.
    abhijit pore likes this.
    04-11-2016 02:36 PM
  14. abhijit pore's Avatar
    Any chance windows will get 2G/3G/4G cellular settings? Something to force the phone into one of them would be very needed.
    That's what i was talking about. This option was not there in Win 8.1 also. And i was hoping it will get Higher Connection Speed setting in Win 10 mobile.here is also same story.
    04-11-2016 02:58 PM
  15. tushardhingra's Avatar
    That's what i was talking about. This option was not there in Win 8.1 also. And i was hoping it will get Higher Connection Speed setting in Win 10 mobile.here is also same story.
    The option made its way in some earlier insider builds but was removed afterwards...don't know why...it is much needed, especially in India.
    abhijit pore likes this.
    04-12-2016 01:22 AM
  16. Alexunder93's Avatar
    Anyone has problem with interface scaling of Shazam app? I had the exact problem in 8.1 also (I think).
    04-12-2016 01:42 AM
  17. Vincenzo Venuto's Avatar
    I have the same problem. No solution...
    04-12-2016 02:27 AM
  18. john24ssj's Avatar
    The more I look at W10 the more it seems an unfinished product, there is so many things missing that were present in W8.1 it feels like a downgrade in some regards.
    abhijit pore likes this.
    04-12-2016 03:49 AM
  19. Maddy90's Avatar
    That's what i was talking about. This option was not there in Win 8.1 also. And i was hoping it will get Higher Connection Speed setting in Win 10 mobile.here is also same story.
    That is a limitation of Blu devices, I think. My brother owns a Blu Win HD LTE running on 8.1 and there's no direct option to choose amongst 2G, 3G or 4G. While I personally use a Lumia 532 and was able to set the maximum connection speed as 2G or 3G in Windows 8.1, and I can use that feature in Win10 Mobile too (build 10586.164). So, I think, it's a device limitation, maybe.
    Easwaran N and abhijit pore like this.
    04-12-2016 08:43 AM
  20. Alexunder93's Avatar
    That is a limitation of Blu devices, I think. My brother owns a Blu Win HD LTE running on 8.1 and there's no direct option to choose amongst 2G, 3G or 4G. While I personally use a Lumia 532 and was able to set the maximum connection speed as 2G or 3G in Windows 8.1, and I can use that feature in Win10 Mobile too (build 10586.164). So, I think, it's a device limitation, maybe.
    Yea, i think that is a LUMIA OEM software which is not available for other manufacturers.
    abhijit pore likes this.
    04-12-2016 08:51 AM
  21. Easwaran N's Avatar
    Yea, i think that is a LUMIA OEM software which is not available for other manufacturers.
    No, this is a BLU specific issue. I had a non Lumia phone before - 8.1. that phone had this option.
    abhijit pore likes this.
    04-12-2016 09:43 AM
  22. Easwaran N's Avatar
    The option made its way in some earlier insider builds but was removed afterwards...don't know why...it is much needed, especially in India.
    This is not a Windows 10 issue. This is BLU specific issue.
    My friend who upgraded to W10 on Lumia640 has this option. My previous phone (micromax Win121, WP8.1) had this option. My current BLU phone (not yet upgraded to WP10) does not have this option.
    abhijit pore and Maddy90 like this.
    04-12-2016 09:49 AM
  23. abhijit pore's Avatar
    Yesterday I have informed Blu about the windows 10 upgrade. I specifically mentioned this Connectivity option not there in windows 8.1 and windows 10.Further also Informed about the firmwae changes.I ask them whether they have any plans for the firmware ota release and official announcement.Possible win 10 release for JR LTE x130E. Today they replied that they have forwarded my details to the techincal support team for further process.
    Easwaran N likes this.
    04-12-2016 10:46 AM
  24. pj1011's Avatar
    i mailed blu support regarding the win10 upgrade early morning today...strange thing happened ...they replied me back the very same day itself....never happened before ....anyways....so here is some good news to share

    Dear Sir,



    Thank you for writing to BLU Support.



    The Win10 international upgrade will be coming soon for BLU devices. Please stay tuned for an update once date is confirmed.



    Thank you for your continued patronage and Patience.



    Thanks & Regards,

    BLU Support



    now I would rather wait for the official upgrade rather than flashing the rom manually....
    the ota update will some be out...for those who want a less tedious experience..
    maybe early next week...just a wild guess...
    04-12-2016 12:44 PM
  25. abhijit pore's Avatar
    Guys I am now downloading 10586.218 now. Lets see.
    04-12-2016 01:44 PM
586 ... 89101112 ...

Similar Threads

  1. BUGS: Running Window 10 Mobile on the BLU WIN HD LTE (x150q)
    By Codster314 in forum BLU Win HD LTE
    Replies: 64
    Last Post: 03-07-2017, 02:33 AM
  2. Best dpi percentage on w10m blu win lte?
    By JMX777 in forum BLU Win HD LTE
    Replies: 15
    Last Post: 07-01-2016, 11:58 PM
  3. Blu win HD Lte x150e - European version
    By Huzefa Khojaim Ragib in forum Windows 10 Mobile
    Replies: 1
    Last Post: 04-16-2016, 08:54 AM
  4. How do I know if my Lumia 640 supports LTE or no?
    By Windows Central Question in forum Microsoft Lumia 640
    Replies: 1
    Last Post: 03-18-2016, 01:00 PM
  5. Replies: 1
    Last Post: 03-18-2016, 11:59 AM
LINK TO POST COPIED TO CLIPBOARD