Sign up now for Disney+
10-21-2017 05:57 PM
124 ... 345
tools
  1. jimh12345's Avatar
    So happy to join the Dead RT Owners club. After an update 2 days ago (1-5-2016), my touch screen is dead. I've found countless posts on this issue, and the usual ineffective replies from MS "support" people, none of which worked. It seems I have 10 days of warranty left so I'll be heading in to the MS store and asking for a fix, or a new unit.
    01-07-2016 05:31 PM
  2. KeegdnaB42's Avatar
    I hadn't messed around with trying to fix mine since I got my sp4 but last night I decided to try again just cause I was bored and sure enough the firmware from November did the trick. I just made sure to install it before any of the other updates it had pending (I had reset it back in October but hadn't used it since). Now it's back in great condition and I'm gonna give it to my dad whose RT is dying as a stopgap until he can replace it with a 3 in the next few months.
    01-10-2016 12:29 PM
  3. ohmsin's Avatar
    Here is the latest that I have tried - and seems to work.

    I recently had the same problem and was just as perplexed as everyone. I even tried the restore option to no effect. The problem lies in the updated firmware driver set. So here is how I got about solving the problem.

    Oh, and before you do this, you need to attach a mouse and keyboard!

    Open "Device Manager" in the "Control Panel".

    If any device listed in the device manager has the exclamation mark, it will likely be the cause of the touchscreen problem.

    On each of the individual firmware driver, left click to open and select the driver tab.

    Select rollback option. You will have at least 2 dated driver versions for selection. Select the older version.
    Do this for the remaining listed drivers and ignore if there is only one version.

    Close Device Manager and drain the battery by setting the screen power settings to "Never".

    When its unable to power up, take another day to manually power up a couple of times.

    Put in your charger after a day, reboot and try. It seems to work otherwise I wouldn't be sending this to you!

    Thanks guys for the power drain suggestion.
    01-19-2016 10:37 AM
  4. StephaAa's Avatar
    It has been quiet for a while. Surface was working like a charm. After installing a couple of regular updates in the morning, the Device claimed to restart for another update in the evening. Now big surprise... no working touchscreen! And this is the replacement device i got from MS. i hate it
    03-12-2016 02:10 AM
  5. Ron Simpson's Avatar
    Got a whole bunch of updates on 3/17/2016 and everything is working great on my Surface 2. No touch issues before or after the updates.
    03-18-2016 11:04 AM
  6. StephaAa's Avatar
    this time i could fix it by following ohmsin post.
    Total battery kill until the point that not even the charging symbol appears. restart - voila.
    Anyway, i had a touch firmware driver with yelllow exclamation mark. i rolled the driver back and on the next restart it installed the newest again. now it works again...
    03-19-2016 06:36 AM
  7. ohmsin's Avatar
    As an afterthought on this "dumb" problem, I wanna add that the problem did recur intermittently, but was irritatingly solved.
    If it does happen again, here's the shortcut -

    Do the rollback and do a shutdown. Wait a minute or so, then power up and check if it works again.
    If it doesn't, switch the device drivers again, power shutdown and wait another minute.
    Repeat until it works.
    I hate the process...and Microsoft.
    04-05-2016 05:47 PM
  8. ohmsin's Avatar
    Hi guys.

    If u still have problems with the touchscreen of the Surface 2, try one more "dumb" trick I noticed.

    Despite what I have noted and mentioned in my previous posts, the touchscreen problem not working after some updates, still occurred randomly. Heck, I even tried reinstalling the RT to original version, and it still happened.

    If you have the same problem after the update, power down your Surface for at least 24 hours. No, don't drain the power, just don't charge the Surface. After a day, try powering up your Surface again. The touchscreen should work again. IF not, power down again for another day, then try using the Surface again.

    What causes it?

    It could be static charge build up on the touchscreen or components that prevents new settings from updates, to properly bootup with the Surface. I think the extended power down discharges the components, albeit slowly and not efficiently, but enough for the Surface to work again.
    05-24-2016 08:36 PM
  9. gattor180's Avatar
    I to have this problem after the latest update from May 2016 was installed the touch screen quit working. I have tried all the suggestions listed on the Microsoft help site but none of the options ahs worked. The machine was working perfectly before the update. If anyone has got any other suggestions please let me know as well. Currently the machine is sitting at home, with a drained battery I am hoping that if I remove the keyboard and memory chip that I can get the touch screen to work again. This is a very inconvenient problem for it seems lots of users. I feel that if a update caused the problem then Microsoft should be fixing the issue for free as it was not caused by user error.

    Gattor180
    05-27-2016 05:16 PM
  10. ohmsin's Avatar
    Gattor180, Try it again to see if the touchscreen works.
    I have been trying the power down method more than a few times - it seems to be a "stable" method of getting the touchscreen to work. I use the surface "occasionally" as I still work out of a desktop so I can afford leaving the surface turned off a couple of days.
    Anyways the root cause is Microsoft's lack of attention and response to this product. Unfortunately we have to hang in there and provide our own support. Wonder if other brands of tablets have the same problem.
    Last edited by ohmsin; 05-31-2016 at 07:52 PM.
    05-31-2016 07:41 PM
  11. StephaAa's Avatar
    and again. Updates 15.06 - restart requested, touchscreen not working again... its a pain.
    06-15-2016 03:47 PM
  12. Ryan Beattie's Avatar
    I had this problem last year after only having the Surface 2 for two weeks shy of a year, and as it was still in warranty they replaced it straight away.

    Now, almost exactly a year again, the replacement's touch screen stopped working after an update 2-3 days ago. Is anyone else having this problem again?
    Nick Malawskey likes this.
    08-01-2016 07:56 PM
  13. Nick Malawskey's Avatar
    Yes, my wife's Surface 2 has shat the bed again.

    We ran into this problem a few months ago -- a non-responsive touch screen. I followed all of the Microsoft trouble shooting steps to no avail. Restored the device as new from the usb, still a no-go. Eventually just let the thing alone for about a month, since without the touchscreen it is completely useless to us.

    A week ago I started it up just for **** n giggles, and low and behold the touch screen was working again! Two days ago she said it installed a new update ... touch screen once again non-responsive.

    In checking the error logs, I came across this reoccurring error: A multitouch device reported inconsistent contact information

    If we had the money I'd just buy her an iPad today (I'm a windows guy, but at least those work reliably). I hate, hate, hate the idea though of bricking a device that's only a year-and-a-half old though.

    Sigh.

    Edit: it also annoys me to no end that support's response is:

    \_(ツ)_/

    "buy a new one"
    08-04-2016 10:48 AM
  14. StephaAa's Avatar
    the problem seems to be coming over and over again. just :
    1.leave with no power cable until the bat is totally empty (Youtube video and auto sleep mode off)
    2.keep pushing the power button over and over again for a day until it is not responding at all (even no empty battery symbol)
    3.leave it somewhere for another day untouched
    4. connect it to the powercable for the first try

    If it is still non responsive to touch repeat the steps. it is annyoing but it helps
    08-09-2016 06:09 AM
  15. sokudo's Avatar
    Hola,

    My Surface 2's touchscreen seemed to exhibit some of the same behaviors listed in some of these posts.

    After boot, it allowed me to login, but after that navigating the unit was not possible. I hooked up a mouse to the unit and tried to navigate and that failed as well.

    I looked at the micro-SD card slot and it seemed the card was inserted OK, but (for whatever reason) I chose to see if I could take the card out. In trying to take the card out I inserted the card more fully into the slot. Once done, navigation capabilities were fully restored. Unit is 100% operational and all is right with the world.

    I hope some others find this helpful.
    08-20-2016 07:58 PM
  16. VinceCL72's Avatar
    Yep, latest update hosed the touch screen again. One update breaks it, the next fixes it.... Over and over again. All I know is that the next update that fixes it will result in my turning off updates forever more.... I'm tired if this and Microsoft's inability to keep this problem fixed.
    09-20-2016 07:47 PM
  17. StephaAa's Avatar
    yep. touch controller dead again and this time even battery drain trick doesn't help. Device cannot be started : Code 10
    11-08-2016 01:20 PM
  18. gonzosgirrl's Avatar
    Did you ever get it working again? Mine has also crapped out again (for the third time). None of the standard reset/rollback/drain procedures are working this time. On the last two resets, I tried only installing the Nov/15 firmware update that supposedly fixes this, but no matter how many times I restart, I get 'update requires restart to complete installation' -- until finally it changes to 'failed'. I am SO frustrated!

    I love this device so much when it works, but I'm not willing to even buy a new one since Microsoft has so thoroughly sucked in rectifying this issue. I haven't seen it mentioned in this thread but when this happens, mine also refuses to recognize my MS Wedge Bluetooth mouse. Everything from the keypad works fine (or else it really would be a brick).
    01-18-2017 10:49 AM
  19. CosmicFrame's Avatar
    Hey guys. I have a SP4, ran into this issue, and this is how I fixed it after a long period of frustration. First, shut it down. Once it's shut down, hold the power and volume up buttons for around 15 seconds. During this time the Surface will boot up, go to a boot menu, restart, and return to the boot menu. When I got to the menu my touch had been restored, I exited out, and everything seems to work now. Hopefully this doesn't happen again with the next update...

    Hope that helps!
    01-22-2017 12:39 PM
  20. StephaAa's Avatar
    Did you ever get it working again?
    No. actually i sold it. i loved it but without touch ...

    old the power and volume up buttons for around 15 seconds
    THat doesn't work on RT devices and this thread is about Surface 2 not 4
    01-29-2017 02:06 AM
  21. billmark's Avatar
    Here is the latest that I have tried - and seems to work.

    I recently had the same problem and was just as perplexed as everyone. I even tried the restore option to no effect. The problem lies in the updated firmware driver set. So here is how I got about solving the problem.

    Oh, and before you do this, you need to attach a mouse and keyboard!

    Open "Device Manager" in the "Control Panel".

    If any device listed in the device manager has the exclamation mark, it will likely be the cause of the touchscreen problem.

    On each of the individual firmware driver, left click to open and select the driver tab.
    THANK YOU!

    I didn't have to roll back the drivers just update all the ones with a ! and now the screen is working again!
    04-23-2017 11:05 PM
  22. fantontheroad's Avatar
    Can someone post the date of the touch driver that has been confirmed working?
    05-08-2017 09:46 AM
  23. gonzosgirrl's Avatar
    I can tell you that IMO, the driver update never helps. I have had this happen with my Surface 2 five times now (it's currently draining the battery - hopefully this ridiculous fix works again). I've tried every solution posted here and on other sites, including Microsoft's), I've also wiped and reinstalled it 4-5 times. Each time it's been after a complete drain and several days trying that it begins working. And each time, the ! triangle beside the firmware driver is still there, even though the touch screen starts working again. I've never been able to get my Bluetooth mouse to work again though.

    I love my Surface, but I'll never buy another one when MS has essentially washed their hands of their own product when it's clearly their issue.
    05-14-2017 05:32 PM
  24. daslondon's Avatar
    Surface 2 RT. Touch had stopped working (device had been used by someone else for a while). I had tried various simple solutions, including refreshing the touch driver, which showed as being faulty. Message was that the driver was up to date.
    Solution (so far...): as mentioned by several people, COMPLETE drainage of battery, which meant hitting the on/off button until the "low battery" symbol failed to appear (I did this over several days). After charging, touch functionality was restored.
    Last edited by daslondon; 10-21-2017 at 06:00 PM. Reason: Added information
    10-21-2017 05:57 PM
124 ... 345

Similar Threads

  1. Lumia 720 - Touchscreen replacement - India
    By Prasun Banerjee in forum Nokia Lumia 720
    Replies: 1
    Last Post: 12-04-2014, 02:30 AM
  2. Replies: 3
    Last Post: 12-02-2014, 06:02 PM
  3. Microsoft working on Xbox wearable tracker?
    By ThePlatypuz in forum Microsoft Band & Band 2
    Replies: 3
    Last Post: 12-02-2014, 05:45 PM
  4. The update was downloaded, but couldn't be opened (8018830f), what do I do next?
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 12-02-2014, 03:35 AM
  5. Replies: 1
    Last Post: 12-02-2014, 12:15 AM
LINK TO POST COPIED TO CLIPBOARD