Use code windows10 andsave 10% on your first Upsie warranty
  1. Dirigent82's Avatar
    So, what are your thoughts after installing the fall update on your SP3?

    I'm liking it so far overall and appreciate the cleaning up and optimizing of the OS. Unfortunately, I have not seen any improvement in battery life (at least with early use so far). Web browsing (using Firefox) still drains mine around 15%/hour, compared to 10%/hour with W8.1. On that front, I am disappointed. I was really hoping for an improvement, but I (we) may have to just deal with it now. I guess ~6 hours on battery isn't atrocious, but it's a far cry from the ~8-9 on 8.1.

    Edit:

    A few quirks/bugs:
    1. On-screen keypad pops up to enter PIN to login even though keyboard is connected and was previously used that way.
    2. Occasionally, booting up after shutting down I'll still get that old problem with System and System Interrupts using a ton of CPU. A restart fixes the issue.
    3. The notification icon doesn't clear after clicking the banner of the notification, or by opening the mail app (if it was a mail notification).
    4. Airplane mode in action center shows as "selected", but it is not actually activated.
    Last edited by Dirigent82; 11-13-2015 at 09:20 AM.
    11-13-2015 09:06 AM
  2. gernerttl's Avatar
    I can't tell you. Mine keeps getting stuck at the 23% mark.
    11-14-2015 01:10 PM
  3. JaimitoFrog's Avatar
    so far so good. still waiting for edge to have swipe back and forth browsing.
    gernerttl, BGrewer and James8561 like this.
    11-14-2015 07:47 PM
  4. gernerttl's Avatar
    I managed to upgrade this morning...finally. So far so good.
    11-14-2015 08:56 PM
  5. Drayk's Avatar
    My upgrade went well but my battery life seems to NOT be as good. This is still the ultimate machine IMO, though.
    11-15-2015 06:19 AM
  6. GSOgymrat's Avatar
    My update went smoothly. I've noticed the startup time is faster. I LOVE that bookmarks and reading lists in Edge finally synch across devices.
    11-16-2015 12:17 AM
  7. jockopablo's Avatar
    1. On-screen keypad pops up to enter PIN to login even though keyboard is connected and was previously used that way.
    I get that often. Also frequently after waking the SP3 doesn't recognize the keyboard at all. Sometimes removing it and replacing it work. Sometimes rebooting works. And sometimes nothing works.
    11-16-2015 08:38 AM
  8. drmodify's Avatar
    mine is still crazy, the fan is noisy as hell just using a few apps. task manager shows 6-15% use. previously I fixed that problem with the adobe filters and resetting the index but now its like there seems no solution to it, Windows audio graph isolation is what's most active... anyone can help me with this?
    11-16-2015 10:36 AM
  9. gernerttl's Avatar
    mine is still crazy, the fan is noisy as hell just using a few apps. task manager shows 6-15% use. previously I fixed that problem with the adobe filters and resetting the index but now its like there seems no solution to it, Windows audio graph isolation is what's most active... anyone can help me with this?
    Here is what it is and what it does. It also says how to stop the process.

    What Is "Windows Audio Device Graph Isolation?" | eHow
    drmodify likes this.
    11-18-2015 04:21 PM
  10. zei20t's Avatar
    Battery life on my i3 is about the same, however on my i7, the battery life is better. and it doesn't appear to get quite as hot. But its stiff friggen hot sometimes!
    11-18-2015 05:05 PM
  11. drmodify's Avatar
    well that was the problem initially but now its something else. CPU is not stressed but fans are whirling away like tornadoes
    11-20-2015 03:23 PM
  12. gernerttl's Avatar
    Here is what it is and what it does. It also says how to stop the process.

    What Is "Windows Audio Device Graph Isolation?" | eHow
    Btw, I shut down the process and in doing so, lost audio capability. So only do this if you don't mind being without sound capability.
    drmodify likes this.
    11-20-2015 06:40 PM
  13. drmodify's Avatar
    Btw, I shut down the process and in doing so, lost audio capability. So only do this if you don't mind being without sound capability.
    Damn can't live with that... But that seems to be resolved somehow for me... now the problem is something else and CPU is 5-10% but the fans can cook an egg
    11-23-2015 11:27 AM
  14. gernerttl's Avatar
    Damn can't live with that... But that seems to be resolved somehow for me... now the problem is something else and CPU is 5-10% but the fans can cook an egg
    This has been a problem with the SP3 since Win 8.1. There doesn't seem to be a single root cause, or at least nobody can find it.

    Right now, mine is warm in the back, but not overly hot. I'm also using it in desktop mode instead of tablet mode. connected to a monitor. I have noticed that if I'm in tablet mode, it seems to run hotter. I haven't actually measured temps though so my comparison is a bit subjective.
    11-23-2015 07:04 PM
  15. drmodify's Avatar
    This has been a problem with the SP3 since Win 8.1. There doesn't seem to be a single root cause, or at least nobody can find it.

    Right now, mine is warm in the back, but not overly hot. I'm also using it in desktop mode instead of tablet mode. connected to a monitor. I have noticed that if I'm in tablet mode, it seems to run hotter. I haven't actually measured temps though so my comparison is a bit subjective.
    Well mine was very stable during Win 8.1. specially during that last few batches of updates. Fans come up sometimes only.. chrome was working well

    Monitoring my temp in windows 10 fall update temp goes 59 to 69 degs celcius with regular use. Fans are quiet yeah but when I turn down the A/C I can hear em.. When I'm multitasking it goes to 80.. then the sounds become louder than the a/c.. it was never like this during Win 8.1

    Guess a clean install is my last resort
    11-23-2015 09:43 PM

Similar Threads

  1. Lumia 920 System apps not updating
    By enahs555 in forum Windows 10 Mobile Insider Preview
    Replies: 1
    Last Post: 11-13-2015, 10:55 AM
  2. Replies: 2
    Last Post: 11-13-2015, 09:57 AM
  3. Replies: 1
    Last Post: 11-13-2015, 09:51 AM
  4. November Update - Where is find my device option?
    By webosdropout in forum Windows 10
    Replies: 0
    Last Post: 11-13-2015, 08:38 AM
  5. Replies: 0
    Last Post: 11-13-2015, 08:26 AM
LINK TO POST COPIED TO CLIPBOARD