1. Lerac1's Avatar
    Hi all,

    I am wondering if all of you are also experiencing my issue with surface pro that every time I start my surface pro 2 my volume rocker and windows logo button are not working. I have to disconnect my power cover and reconnect and suddenly magically the volume rocker and windows logo button start to work again. I know i boot my computer with the keyboard backwards meaning I am disabling the keyboard. However I think it is enormously stupid my volume rocker and windows button should not work until I disconnect keyboard.

    Another annoyance I have is my keyboard (power cover) is not recognized. This happens all the time even after reconnection it multiple times. This much that I never mind it. Is there anything I can do to fix this? It annoys me so much....
    03-23-2015 09:54 PM
  2. Lerac1's Avatar
    Nobody at all with this issue?
    04-07-2015 10:02 PM
  3. RTGent's Avatar
    Not here. Not ever. I'm entering my third year with an RT, and second with the SP2. I use the RT every day for 1-3 hours a day, and the SP2 an average of 5-7 hours a week. Each has a type keyboard, and they're both attached constantly, right-side-up always, and 80-90% of the time I'm in tablet mode with the keyboards folded over. My RT keyboard is now fraying at the connection edge, where it is often resting on my jeans or whatever. Two or three days a week I notice the auto-off/on functionality of the keyboard is lost on the RT; I detach and reconnect once, and presto. This has worked that way from day one and it's a 3-second solution. I never work plugged in, and I have never experienced your rocker and logo button issues -at least not to remember it. I handle and toss around both devices the same way, and I think the heavier weight of the SP2, makes it disconnect more often, although without the auto-off functionality and always in tablet mode, I often don't notice a lost-connected SP2 keyboard.

    I'd suspect I had a bad unit or keyboard and return it. Good luck getting past your problem.
    04-10-2015 09:15 AM
  4. Lerac1's Avatar
    Thank you for replying, funny thing is i never have this issue with my type cover (meaning not power cover)
    05-11-2015 07:13 PM

Similar Threads

  1. Replies: 2
    Last Post: 10-01-2015, 08:53 AM
  2. Windows 10 for other phones!
    By asa2015 in forum Windows Insider Program
    Replies: 9
    Last Post: 03-25-2015, 09:24 AM
  3. Windows 8.1 Tablet Micro USB to HDMI
    By cjloyola in forum General Desktop, Laptop & Tablet Discussion
    Replies: 2
    Last Post: 03-24-2015, 01:42 AM
  4. Tubecast for Windows 8.1 lets you do more than just watch Youtube videos
    By WindowsCentral.com in forum Windows Central News Discussion & Contests
    Replies: 1
    Last Post: 03-23-2015, 09:04 PM
  5. Why does the notifications volume keep moving to zero on my Nokia 620?
    By Windows Central Question in forum Windows Phones
    Replies: 1
    Last Post: 03-23-2015, 07:41 PM
LINK TO POST COPIED TO CLIPBOARD