1. Montgomery Badleford's Avatar
    I've posted this question on Microsoft's community forum, but I guess it wouldn't hurt to try here too.

    I have a Surface Pro 2 running Windows 10, and I use the Power Cover. Every now and then the mouse in my Power Cover stops working properly (that has happened to me with all the Type Covers and Surface tablets I've used, so it's not peculiar to my device). The way I usually fixed that is by disconnecting the Cover and connecting it again, but since upgrading from Windows 8.1 to Windows 10 I've noticed that after I disconnect the cover my CPU usage shoots up due to three processes, namely "Windows Driver Foundation - User-mode Driver Framework Host Process", "Service Host: Local System (Network Restricted) (15)" and "System". Collectively they cause my CPU usage to go above 50%, which then causes my Surface to warm up. The only way to return it to normal is by restarting the tablet. The firmware for my Surface Pro 2 is up to date, as are the drivers for my Power Cover. Is there any way to fix this issue permanently?
    jonathanrn likes this.
    08-12-2015 09:41 AM
  2. jonathanrn's Avatar
    I am having the same issue with my Surface Pro. High CPU usage with basically the same processes you are talking about (Network Restricted (13) instead of (15)). My CPU usage is around 60-70% at idle. I came home to the fan blowing away this evening and about a minute ago it just fixed itself. Weird. Please respond to this thread if you have any more information. Maybe it was a bug in the cumulative update?

    Jonathan
    08-12-2015 10:54 PM
  3. Montgomery Badleford's Avatar
    After upgrading to Windows 10 my Surface Pro 2 also used to get very hot, but that problem has stopped since I did this:

    How to Stop Windows 10 From Uploading Updates to Other PCs Over the Internet

    Now it only gets hot when I disconnect my type cover and re-connect it, but it stops when I restart the computer.

    You could also try changing your antivirus (I'm using 360 Total Security).
    08-13-2015 05:27 AM

Similar Threads

  1. Surface Pro 3 Activation problems
    By jasqid in forum Microsoft Surface Pro
    Replies: 8
    Last Post: 08-20-2015, 07:39 PM
  2. Surface Pro 3 with Windows 10
    By WindowsGirl in forum Windows 10
    Replies: 3
    Last Post: 08-12-2015, 03:37 PM
  3. Replies: 0
    Last Post: 08-12-2015, 08:18 AM
  4. Replies: 1
    Last Post: 08-12-2015, 06:07 AM
  5. What is the $WINDOWS.~BT folder in wiindows 10 after update ?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 08-12-2015, 05:36 AM
LINK TO POST COPIED TO CLIPBOARD