Firmware from 10/28 keeps reinstalling

berfles

New member
Jun 20, 2014
46
0
0
Visit site
I keep getting messages that my PC needs to reboot, and I go into the history and see the friggin 10/28 firmware is pending a reboot. Again. For the fifth time. What the hell is going on here?
 

Guzzler3

New member
May 4, 2012
1,398
0
0
Visit site
You too?

I'm not sure what to tell you. I went as far as downloading the firmware files and updating everything manually. And Windows Update still tries to reinstall the firmware. I really don't want to factory reset to clear it up, but I might have to.
 

Tunno79

New member
Dec 17, 2012
17
0
0
Visit site
I had the exact same problem. Caused problems with the Pen touch driver. After 3 hours on the phone with MS support I ended up having to do the following:

1. Turns the recovery image was corrupted. Hard to believe since it was a replacement Surface.
2. Had to download a new image from here:
Since I have less than 10 post I cannot post the link. you will need to google the link but it is under Surface support website.
3. Follow the instructions. Log in to your MS account provide your Surface serial number and follow the instructions. You will need a minimum of a 16 GB USB drive. Make sure the USB drive is formatted to FAT 32. Also make sure that you extract the files from the downloaded zip file to a temp folder and then copy to your USB drive. Do not have and peripherals connected to the Surface such as the keyboard.
Install the new copy by rebooting with the USB drive connected. Make sure you select to Repartition the hard drive so that the new image is placed on the back up partition for future use.
Ignore any prompts of recovery keys. If you be a American Megatrends "Bios" boot screen asking for keyboard input, since there is no keyboard connected and connecting the keyboard does not work, just power off the Surface and power on again. This time it will complete the Boot.
After initial boot up the error in device manager still appears to be there. However selecting the windows updates, including the 10/28/2014 Firmware update, it will install successfully.
After some further windows updates all completed successfully, the driver in question is working correctly and the pen is now recognized and works as expected.
 

Guzzler3

New member
May 4, 2012
1,398
0
0
Visit site
And the download is taking FOREVER. 4 hours right now. There is something wrong in the Microsoft network, as everything else I try to download is on par of what it should be.
 

Guzzler3

New member
May 4, 2012
1,398
0
0
Visit site
Man, it took me over 8 hours to download the newest recovery image from MS. I even did a support chat trying to explain to them that there was something wrong with their routers (a simple traceroute showed their network was horked). They wouldn't take my word for it, even after I told them I was once a MCP, that also did a short stint being a network admin.

Well, I did the full wipe, refresh on my SP3. Did the firmware update first, by itself. So far, so good. I'll have to wait a couple days to see if the firmware tries to reinstall again, as it was every couple days it would pop up to try to install again. I do have to admit, that things are running much better now, and quite a bit quicker.
 

berfles

New member
Jun 20, 2014
46
0
0
Visit site
Yep, I'm downloading it at about 350KB/s, ridiculous.Plus it's going to force me to reboot in 15 minutes so it's pointless to start right now.
 

Guzzler3

New member
May 4, 2012
1,398
0
0
Visit site
Yep, that's about the transfer rate I had to go through. Fortunately, I had an old laptop lying around that I setup not to go to sleep and just let it download.

The one nice thing, was after doing the refresh, the number of updates required was surprisingly small. It looks like they slipstreamed a lot of the previous updates in the new image.
 

berfles

New member
Jun 20, 2014
46
0
0
Visit site
Well, I installed the update one more time, then grabbed some sort of "optional" 730MB update, and after I rebooted I had the 11/18 firmware ready to install. Installed that last night, so far no repeats but I guess time will tell. Would be nice if I was able to work through this without reformatting though.
 

Guzzler3

New member
May 4, 2012
1,398
0
0
Visit site
It's been three days since I refreshed and I haven't had any prompts to reinstall the firmware. And my SP3 is running much better than before. Granted, I haven't installed as much software as I had previously. Keeping it simple, with just the software I use on a daily basis.
 

anguilla1980

New member
May 1, 2008
337
0
0
Visit site
Well, I installed the update one more time, then grabbed some sort of "optional" 730MB update, and after I rebooted I had the 11/18 firmware ready to install. Installed that last night, so far no repeats but I guess time will tell. Would be nice if I was able to work through this without reformatting though.

EXACTLY the same thing for me. After doing the 11/18 firmware it hasn't asked again to install it. Hopefully that fixed some things.
 

berfles

New member
Jun 20, 2014
46
0
0
Visit site
Well, now 11/18 firmware keeps trying to reinstall. What a pain in the ***, guess I have to re-image it after all if it's going to do this with every new firmware update.
 

berfles

New member
Jun 20, 2014
46
0
0
Visit site
And now the 1/15 firmware just popped back up to install. This is after I re-imaged the laptop as discussed earlier in this thread.

I am beyond pissed right now if this is going to keep happening.
 

Members online

Forum statistics

Threads
324,052
Messages
2,244,895
Members
428,161
Latest member
Adam@2561