Forcing WP to use 3G-only

Kimi Alin

New member
Aug 13, 2013
174
0
0
Visit site
Hey there! I was wondering if it's possible to force my Lumia 920 to use 3G only if it's available. My problem concerns situations when there are both 2G and 3G connections available and 3G signal is not so strong while 2G is much stronger, so phone prefers taking 2G signal, which means not been able to use internet at all. It also takes battery life when the phone is constantly switcing between 2G and 3G. I experience this issue a lot on some areas I visit a lot. For instance there are several places where there are these 2G amplifier towers nearby, which leads to no 3G-connection. This is annoying problem and I would like to solve it.
 

rockstarzzz

New member
Apr 3, 2012
4,887
1
0
Visit site
There is no field test menu accessibility any more after the recent update so you will be able to select highest connection speed but not the lowest. If you get an option (depends on your network provider) in settings -> cellular/mobile network -> highest connection speed to 2G or 3G - you can set that. But you can't set lowest connection speed or single G.
 

pankaj981

New member
Jul 10, 2012
6,131
0
0
Visit site
Well field test is still enabled on some Lumia models.

OP: Dial ##3282# and see if you get something. If yes then please post back, if not then you're out of luck!
 

pankaj981

New member
Jul 10, 2012
6,131
0
0
Visit site
Well there is Field test on my phone but I don't understand anything about it :straight: What use it would it be for me?
ok then you can force 3g always on. Goto field test, click on three dots in the bottom and click settings, network type set to 3g only and click windows key and that's about it, now your phone is locked to 3g only. But you will lose signal when there is no 3g signal and then you will have to go back and set the network type to automatic. I hope this makes sense.

Do post your results.
 

Kimi Alin

New member
Aug 13, 2013
174
0
0
Visit site
I found it and changed it to 3G but how do I confirm it? I mean after I did that and went back to metro and back to field test I saw it was on automatic again? Odd.
 

pankaj981

New member
Jul 10, 2012
6,131
0
0
Visit site
It does seem to stick but resets when you open the app again, check the network when you select 2G, the n/w resets and you see phone connected to E
 

Kimi Alin

New member
Aug 13, 2013
174
0
0
Visit site
Okay, it seems to be working but I can't really tell if it actually works since I have to test my mobile connection in common places I spend time and which have that problem but it looks like its forcing 3G at all times. So now if there is no 3G connection now, phone will not have any connection? Does it also mean I cannot call calls either? Well I will see that eventually. Thanks for your help! :smile:
 

Kimi Alin

New member
Aug 13, 2013
174
0
0
Visit site
Thats fantastic! What code did you use?

##3282# as suggested by pankaj981 on the third post. After some use I have decided to change it back to automatic because my battery has started to drain faster. I don't know if that's the case but I will test if my battery lasts longer now.
 

samzephyr

New member
Aug 28, 2013
6
0
0
Visit site
Hi Pankaj. Any idea about the new code for the field test in lumia 820 after the amber update. ##3282 doesn't work out! Kindly reply.
 

Members online

Forum statistics

Threads
323,235
Messages
2,243,497
Members
428,044
Latest member
djysrv