How do I stop command line interpreting function (and other) keys?

r76

New member
Apr 15, 2021
1
0
0
Visit site
I am running neovim from the command line on Windows 10. It runs ok, but function key presses are getting intercepted by the actual command shell (ie, cmd.exe) rather than being passed through to the running application (which in my case is neovim).

This "feature" is described in more detail here...
http://smallvoid.com/article/winnt-command-prompt-shortcuts.html

Or, at least that is what I THINK is happening. If I press F2, F3...F5 (for example), I get the characters 'B', 'C', 'D', 'E'.

F6 seems to work ok and prssing that does indeed pass through the key <F6> to neovim.

I thought the problem was limited to just the function keys, but have just realised that key sequences such as Ctrl-v are also being interpreted by "something" (in this case, it performs a paste, which I know is standard Windows behaviour, but is a problem in this case).

I have tried using cmd.exe, and powershell - same result.

I have installed ConEmu terminal (which is pretty good by the way) but that does not provide an actual shell so it still has to run cmd.exe (or powershell)

How can I stop cmd.exe eating and acting on the function keys, and stop it interpreting things like Ctrl-v and performing a "paste"? Or failing that, is there a different shell I can install? (installing the Linux sub-system is not an option, unfortunately)

Please note that this has nothing to do with BIOS settings and the 'Fn' key that is often found on many laptops, or the "Windows" key. It's also not a driver problem. I only point this out because all the answers I have found up to now seem to focus on these issues.
 

Members online

Forum statistics

Threads
319,640
Messages
2,237,907
Members
427,603
Latest member
AlexJones37