I really want to love WP...

Beppe Gissi

New member
Jul 20, 2014
124
0
0
Visit site
...and I do, but it's such an irrational thing.

I've been using WP for a week now, and besides all the fantastic things here (speed, UI, the "feel" you have a premium OS even if you paid just 100 ?), I've been through some really painful issues. And they're a lot for only one week of usage.

-IE keep crashing everytime I play an embedded YouTube video
-IE sometimes crashes when I write some comments (also on here)
-Battery Saver went crazy yesterday and didn't provide proper informations for a while (it showed that only IE and Gmail were using battery, when I've been using WhatsApp all day and it had no usage)
-I fixed Battery Saver, then just now I updated it to the new version, and it doesn't open anymore. I've setted "show usage in last 48 hours" and since then it just crashes. I can't do anything.

I still love WP, but damn...I never imagined I would have all this problems in my first WP week.
 

spaulagain

New member
Apr 27, 2012
1,356
0
0
Visit site
What device? I've had no such issues. YouTube in browser has been pretty solid on WP for me. Especially with the better video controls in 8.1.
 

Beppe Gissi

New member
Jul 20, 2014
124
0
0
Visit site
What device? I've had no such issues. YouTube in browser has been pretty solid on WP for me. Especially with the better video controls in 8.1.

630. Try to tick the new option "show usage in the last 48 hrs" and maybe you will see. YouTube in browser works properly only on mobile site, which is ok, but is a pain when it comes to embedded videos in websites.
 

Beppe Gissi

New member
Jul 20, 2014
124
0
0
Visit site
So, now I have done a soft reset (2nd in few days lmao) and battery saver doesn't crash anymore. But now every app has 0% usage.

This is getting ridiculous, I think battery saver hates me.
 

Karthik Naik

Banned
Jan 17, 2014
1,616
0
0
Visit site
...and I do, but it's such an irrational thing.

I've been using WP for a week now, and besides all the fantastic things here (speed, UI, the "feel" you have a premium OS even if you paid just 100 ?), I've been through some really painful issues. And they're a lot for only one week of usage.

-IE keep crashing everytime I play an embedded YouTube video
-IE sometimes crashes when I write some comments (also on here)
-Battery Saver went crazy yesterday and didn't provide proper informations for a while (it showed that only IE and Gmail were using battery, when I've been using WhatsApp all day and it had no usage)
-I fixed Battery Saver, then just now I updated it to the new version, and it doesn't open anymore. I've setted "show usage in last 48 hours" and since then it just crashes. I can't do anything.

I still love WP, but damn...I never imagined I would have all this problems in my first WP week.

download youtube HD
 

Karthik Naik

Banned
Jan 17, 2014
1,616
0
0
Visit site
So, now I have done a soft reset (2nd in few days lmao) and battery saver doesn't crash anymore. But now every app has 0% usage.

This is getting ridiculous, I think battery saver hates me.

dont rely on battery savers on any os imho
they all use up battery themselves most of the time
 

Members online

Forum statistics

Threads
323,160
Messages
2,243,365
Members
428,034
Latest member
shelton786