Lumia 521 not displaying all WIFI networks available

dxmemxpac

New member
Sep 6, 2013
25
0
0
Visit site
My Lumia 521 just stopped recognizing a wifi network - I tried to turn on/off the phone and the wifi to no avail. The network seems to pop in and then disappear quickly. I know it's not the wifi network itself as my blackberry and tablet "see" the network and can connect to it no problem. I also tried a soft reset - (hold down power + volume) and removing the battery. Nothing - anyone have any suggestions outside of doing a hard reset?

Thanks in advance.
 

Corepc

New member
Mar 11, 2012
1,331
0
0
Visit site
What is working did something change on your network ?
What is wifi setup has WEP, WPA2-PSK (preffered) ?
Did you recently upgrade to GDR2/Amber ?
 

dxmemxpac

New member
Sep 6, 2013
25
0
0
Visit site
What is working did something change on your network ?
What is wifi setup has WEP, WPA2-PSK (preffered) ?
Did you recently upgrade to GDR2/Amber ?

Nothing changed on the network - I don't know the setup it is a network in my office. I was able to connect to the network for over a month with no issues - I got amber when it was released a while ago and have always been able to connect. It just stopped working yesterday. Weird thing is that if I move around the floor outside of my office, the Lumia can "see" it and connect to it with no issues.
 

Corepc

New member
Mar 11, 2012
1,331
0
0
Visit site
Nothing changed on the network

Weird thing is that if I move around the floor outside of my office, the Lumia can "see" it and connect to it with no issues.

well did anything change in your area or any new devices that use wireless network added in your office. Have you tried powering on and off the phone itself. Try removing the network under WiFi and reads it.
 

dxmemxpac

New member
Sep 6, 2013
25
0
0
Visit site
well did anything change in your area or any new devices that use wireless network added in your office. Have you tried powering on and off the phone itself. Try removing the network under WiFi and reads it.

No new devices and nothing changed in my area. I powered on and off the phone and removed the network under WiFi. I think the only option may be a clean wipe.
 

Hotrippr

New member
Jan 25, 2014
36
0
0
Visit site
Youre lucky its resolved,
I frequently have problems after leaving and returning home only to find my phone connecting forever, the only way it responds is by restarting my phone. I hate this problem!!!! I had the problem on both my 520 wp8, and still have the problem on my 521 wp8.1.
 

Members online

Forum statistics

Threads
322,485
Messages
2,242,092
Members
427,936
Latest member
isabellefrosluis