Lumia 950 xl brightness bug?

LightenSkies

Member
Apr 25, 2016
494
0
16
Visit site
Hey guys. I been having a problem with my Lumia 950 xl brightness sometimes it gets stuck at a percentage and stays that way till I reboot the phone. Is anyone having this problem? I'm running the latest firmware and OS. I just get annoyed that even if I slide the slider on brightness nothing happens. :/ only reboot fix it. Thanks for any info.

-Daniel
 

Mesbah

New member
Dec 31, 2015
396
0
0
Visit site
Yes, 950XL screen brightness has its own mind deciding what to do does not care about settings and uses a lot of battery power.
 

LightenSkies

Member
Apr 25, 2016
494
0
16
Visit site
Thanks for reply. I felt like I was the only one with this issue since no one else replied. Does your brightness get stuck at times? That you would have to reboot?

-Daniel
 

Mesbah

New member
Dec 31, 2015
396
0
0
Visit site
Brightness getting stuck never happened on my 950XL even when I opened its box. If it happened to me I could have heart attack:amaze:
I suspect you have a combination of some updates not installed properly AND buggy apps, or even if you have a SD card and moved apps from device to SD or vice versa. such combo problems best solved by a clean hard RESET of phone AND not using back up copy but rather reinstalling each app from scratch.
I am also finding frequently I have to uninstall then reinstall some apps that then run smoothly plus solve some other problems that I never could fix before.
 

anon(5326758)

New member
May 5, 2011
110
0
0
Visit site
I'd never had brightness stick like that, but I have had issues... With earlier builds I'd had the opposite problem, where I would set the brightness to say 25% and after a reboot it would reset to 50%, and I'd have to reset it back to 25%. This hasn't happened again on recent builds - the brightness remains the same even after reboots.

I am running build 10586.218 and firmware 16025
 

LightenSkies

Member
Apr 25, 2016
494
0
16
Visit site
I'd never had brightness stick like that, but I have had issues... With earlier builds I'd had the opposite problem, where I would set the brightness to say 25% and after a reboot it would reset to 50%, and I'd have to reset it back to 25%. This hasn't happened again on recent builds - the brightness remains the same even after reboots.

I am running build 10586.218 and firmware 16025

Im also using the newest firmware. But ya I notice at times my screen brightness at times will get stuck at 100% and tapping on the tile in notification to lower brightness would either just not change or the numbers would change like lets say I tap it to be 25% it will still act as its 100% brightness. Only way to fix this issue is to reboot phone.
 

darth furious

New member
Mar 6, 2014
89
0
0
Visit site
the new fast ring 14332 doesn't use percentages anymore (0,25,50,75,100). Instead it says "darkest,darker,suggested,brighter,brightest" and it seems to work better than the old build on auto mode.
 

LightenSkies

Member
Apr 25, 2016
494
0
16
Visit site
the new fast ring 14332 doesn't use percentages anymore (0,25,50,75,100). Instead it says "darkest,darker,suggested,brighter,brightest" and it seems to work better than the old build on auto mode.

Is the new build smoother? Last time I try it. My phone was bugging out like its on a dance floor lol
 

darth furious

New member
Mar 6, 2014
89
0
0
Visit site
I suspect very much freezes & crashes mostly are due to buggy apps.
probably. But also get problems like my alarm doesn't give an audible sound anymore. It shows up on the notification center but no sound or alert. Overslept 30 min this morning. Luckily I woke up on time last week without the alarm but it's annoying when it works 40-60% of the time
 

mtf1380

Active member
Nov 30, 2015
1,845
0
36
Visit site
the new fast ring 14332 doesn't use percentages anymore (0,25,50,75,100). Instead it says "darkest,darker,suggested,brighter,brightest" and it seems to work better than the old build on auto mode.

darth, I am on 14332 (950XL DS, USA) and my brightness slider (Settings>Display>Adjust brightness level) (auto is OFF) stills shows 1-100%, and quick action screen brightness settings remain at 25,50,75,100% increments... ?
 

darth furious

New member
Mar 6, 2014
89
0
0
Visit site
darth, I am on 14332 (950XL DS, USA) and my brightness slider (Settings>Display>Adjust brightness level) (auto is OFF) stills shows 1-100%, and quick action screen brightness settings remain at 25,50,75,100% increments... ?
yeah, it shows percentage if auto is off. Turn auto on and it will show darker-brightest
 

Mars2003

New member
Jul 12, 2011
83
0
0
Visit site
No, I still get this issue ok my 950 (production build). I can't work out what the sequence it's that triggers it other than it's always after I unlock it.
 

raiderfan247365

New member
Apr 4, 2009
28
0
0
Visit site
I get have this issue as well, pretty wack as I have only had my 950 XL for a few weeks now, this bug is annoying. Chances are it won't be fixed either as MS seems to be distancing itself from these devices.
 

Members online

Forum statistics

Threads
323,163
Messages
2,243,368
Members
428,034
Latest member
shelton786