Nokia 925 Signal dropping and not allowing calls unless restarted/reset using airplane mode

mutunekk

New member
Nov 19, 2012
10
0
0
Visit site
I'm having an issue with my nokia 925. whenever I travel in a car my phone loses signal to 1 bar and it doesn't recover until the phone is restarted or put into airplane mode. This is happening every time I travel (every day I drive from my home to my office) and is getting more and more frustrating... ive tried different firmwares, resets and even replacing my simcard but nothing is working. I even tried the same simcard same route but with a HTC 8x but the phone worked perfectly no issues. Does anyone have a suggestion on how to fix this?

Below is an example of the issue;

Signal reduced to 1 bar;
WIN_20130819_074514.JPG

When I try to call;
WIN_20130819_074525.JPG

The call fails after a couple of seconds...
WIN_20130819_074556 (2).JPG

After I switch airplane mode on and off...
WIN_20130819_074728.JPG
 

Laura Knotek

Retired Moderator
Mar 31, 2012
29,412
25
48
Visit site
What has T-Mobile said about this other than replacing the SIM?

Would you be able to replace your device with another one from T-Mobile?
 

mutunekk

New member
Nov 19, 2012
10
0
0
Visit site
I tried that and it worked fine for the day... Now pretty much everywhere i go i need to restart the phone. I've been travelling for some time but i will return it as soon as i can and hopefully that will fix it.
 

anthonykash

New member
Jul 24, 2013
8
0
0
Visit site
I've had tons of connection problem with this phone. I flashed my first phone back to stock with the Nokia utility that the store uses floating around the next. when that didn't work I asked and received another one, same issues still. I'm coming from an iPhone and Android phones. Between the crappy signal and the limited apps on WP8, I feel like I'm using a beta mobile phone. If I could I'd got back and get an iPhone or Android phone. Windows phone needs 9 months to a year for their App ecosystem to catch up and apparently Nokia needs that time to figure out how to construct a solid phone. they should worry less about camera pixels and more about actual signal/voice quality. After all, It's a PHONE NOT a camera.
 

BeeCee1972

New member
Sep 16, 2013
3
0
0
Visit site
My wife and I have the same phone, Lumia 925, with the same problem on both phones. We can be at the same location and one of us will have no bar and the other one be just fine. I have kept my phone as a baseline and have been trying to troubleshoot her phone. We have replaced the SIM card and have replaced the phone, twice. Nothing has corrected the problem. From talking to tech support, I do not think T-Mobile realizes the extent of the problem. Perhaps someone need to Tweet Legere to get the ball moving.
 

troylytle

New member
Nov 9, 2012
881
0
0
Visit site
Unique situation. I live in a small Tennessee town and it is the same here. I brought it to Nokia's attention and sent them my old phone so they could see what was going on and fix it. I check in from time to time and last time they said gdr3 will fix it. I just pin my airplane mode to the start screen as to avoid an extra tap. Till they fix it at least.
 

BeeCee1972

New member
Sep 16, 2013
3
0
0
Visit site
Have you notice any difference when Wi-Fi calling is turned on vs. turned off? My latest troubleshooting efforts have been focused on disabling Wi-Fi calling. Do you have any input on whether Wi-Fi calling has an effect on this problem?
 

SCXR

New member
Feb 24, 2013
14
0
0
Visit site
I was having the same issue. I turned of LTE and it got better. Setting - system - cellular - change highest connection speed to 4G.
 

BeeCee1972

New member
Sep 16, 2013
3
0
0
Visit site
After turning off my Wi-Fi calling over a month ago, I have not had the problem occur again.

A few weeks ago, an update came through and my wife's phone has not had the same problem either. It may be coincidence, but maybe T-mobile figured out what the problem was and fixed it.
 

Jalis_lokong

New member
Nov 25, 2013
5
0
0
Visit site
actually I have the same problem, I switched handsets and sim cards as well but nothing! The workaround I discovered which works for me is to have DATA connection off by default and only switch it on when I need it. Never leave it on while driving or walking essentially any movement that would involve your phone attaching to different cell towers. I think the phone software has issues dealing with an active data connection as you move between 2G and 3G coverage areas and handing over the active connection between cell towers.
 

David Horn

New member
Apr 21, 2011
64
0
0
Visit site
Take the SIM out, clean the contacts, and make sure it's perfectly square in the tray before putting it back in. Solved the problem for me.
 

Jalis_lokong

New member
Nov 25, 2013
5
0
0
Visit site
David, I do not think its the sim card, seems to me its more of the phone software dealing with the phone radio moving between cell towers and keeping the data and voice active at the same time. I have changed SIM cards and I still have the same issue. :-(
 

AlexanderPD

New member
Feb 25, 2012
141
0
0
Visit site
i had 3 windows phone:
1) HTC Mazaa
2) Lumia 720
3) Lumia 925

First two had this problem, but after some "try to call, fail, retry" spam (usually 5 or 6 times) the phone get it signal back and works well.
I have Lumia 925 from just a couple of weeks and it still doesn't show this problem! I think too its totally software related, maybe a bug that in some condition appears more frequently. Since we don't have a clue about that those *conditions" are.. you can try to soft and hard reset, maybe you can reduce the problem!
 

Jalis_lokong

New member
Nov 25, 2013
5
0
0
Visit site
I rally do hope the newest update fixes this! I have not yet received it, I keep checking for updates but till now I have not been lucky. Patricio, do you have the changelog that actually shows this?
 

Jalis_lokong

New member
Nov 25, 2013
5
0
0
Visit site
the Lumia Black update to firmware 3051.40000.1345.1011 seems to have sorted out the issue for me! :) :) Ever since I updated it earlier this year everything seems to be OK.
 

Members online

Forum statistics

Threads
323,628
Messages
2,244,107
Members
428,092
Latest member
raymowen