Nokia 930 Bluetooth Dialing Problematic After Denim Update

mrf00x

New member
Feb 9, 2015
2
0
0
Visit site
I updated my 930 over the weekend to AU version: 02540.00019.14484.37008.

Everything worked perfectly fine and still does BUT when I went to make a phone call in my Mazda 3, the phone dials out but audio on stereo does no longer switch to headset mode.

After 10 seconds the bluetooth button when making a call turns off. You can hear the phone ring as you wait for the other person to answer but at this stage bluetooth headset isn't taking over.

When the other person answers your call and you press bluetooth on the phone it works and the headset takes over your stereo.

Note this was no issue prior to the update. I have reset phone defaults and did same for car stereo including deleting any existing bluetooth pair.
In my line of work this phone cannot be used as you need to make the call, hear it ring through the phone then wait for other person to answer before bluetooth headset can take over.
Audio streaming has no issues neither does when someone calls me and I answer the phone from the steering wheel. It is only outgoing calls this happens.

I am open for any suggestions, but note that I am in IT and have tried all the basics and started from scratch with no results.

What would you guys suggest?
 

Roy Khoh

New member
Feb 4, 2015
59
0
0
Visit site
I've got the same firmware, and it is working fine with my Ford Fiesta.
OS version: 8.10.14219.341
Ford "my sync", however, is meant to be driven by Microsoft so that might have something to do with it.

I suggest, you try your phone in another car to see if it reacts the same.
What about another Bluetooth device? I don't think the phone will care if it's a car or not.

And I'm assuming "reset phone defaults" is the hard reset? The Settings --> About --> reset your phone.
I had problems with accelerometer after denim update, so hard reset and all was fine afterwards. Didn't get a chance to pair with my car before the hard reset.
 

mikeyjames

New member
Feb 22, 2013
14
0
0
Visit site
Hi
If I am understanding you properly, a similar thing has been happening to me since Cyan in my Ford Falcon (FG Mk2). But only happens to me with voice dialling. Since Denim, I go "Hey Cortana", then "Call my wife", Cortana goes "certainly calling your wife", then I only hear silence through the car audio. If I transfer the call back to the handset I can hear okay, but transfer back to the car audio then silence again. If I hang up and use the steering wheel button to call the last dialled number it then works fine. Silence after voice dial over bluetooth in car - Microsoft Community

Streaming music has also been a nightmare since Denim - constant stuttering.

Cheers
Mick
 

Roy Khoh

New member
Feb 4, 2015
59
0
0
Visit site
1. Used Ford Fiesta to "call voicemail" - entirely through Bluetooth car speakers
2. Used "Hey Cortana" - could not hear the "bleep" when Cortana activates, can see activation through car monitor/display, then "call voicemail" and the rest was via Bluetooth car speakers.
3. Handled the phone to dial voicemail - entirely through Bluetooth car speakers.
4. Used car to "call Cortana" - Bluetooth car speakers activated and car display indicating connection to Cortana then "call voicemail", entirely through Bluetooth car speakers.

Considering it was working before denim update, viable conclusion is software.

Not sure what the Bluetooth info would be part of:
OS version: 8.10.14219.341
Firmware revision number: 02540.00019.14484.37008
Hardware revision number: 2.0.0.2
Radio software version: 201c110.00039.0001

And what about that "alternative Bluetooth" setting?

You don't happen to have another set of Bluetooth device active in the car do you?
Your initial post mentions "Bluetooth headset" and I haven't heard anyone reference the car's speakers as "headset" before.

Otherwise, you might be a victim of "bad update" that most of us here have suffered.
Usual steps are:
1. Reboot/Restart the phone
2. Soft reset
3. Hard reset
4. (Re) Flash

I was lucky with only needing to resort to Hard Reset.
 
Last edited:

mrf00x

New member
Feb 9, 2015
2
0
0
Visit site
Hi

This is confirmed to be an issue on 930. Microsoft has contacted me and they agree there is an issue. They are investigating and have been contacting me daily with an update.
 
Last edited:

Members online

Forum statistics

Threads
323,207
Messages
2,243,457
Members
428,045
Latest member
Ridhwan