Type Cover not working on Surface Pro 3

cjfisch

New member
Oct 8, 2016
1
0
0
Visit site
I have a Surface Pro 3. Yesterday (10/4/2016), the type cover stopped working at around 4:30PM EST. The keyboard, touchpad, and backlight all do not work in the OS or the BIOS with VOL+ and Power. I have also tried to force restart this multiple times this way. All updates are installed and I tried manually installing anything that I could find on Microsoft's site. I stopped at a Best Buy and my type cover works on other Surfaces and their covers do not work on mine. I have a feeling that it is a firmware issue, and therefore an OS restore will not fix it. Where should I go from here?
 

oruworld

New member
Oct 14, 2016
2
0
0
Visit site
I have a Surface Pro 3. Yesterday (10/4/2016), the type cover stopped working at around 4:30PM EST. The keyboard, touchpad, and backlight all do not work in the OS or the BIOS with VOL+ and Power. I have also tried to force restart this multiple times this way. All updates are installed and I tried manually installing anything that I could find on Microsoft's site. I stopped at a Best Buy and my type cover works on other Surfaces and their covers do not work on mine. I have a feeling that it is a firmware issue, and therefore an OS restore will not fix it. Where should I go from here?
 

garryknight

New member
Nov 10, 2015
104
0
0
Visit site
My type cover (SP3) went dead a few days ago. No keys work, the trackpad doesn't work, the backlight doesn't work.

I've tried checking for updates (weren't any), the 2-finger restart (in the dock and out of it, with type cover and without), tried to reinstall drivers (the complete SP3 driver package), continually unplugging and unplugging, and even waved a dead chicken over some goat's entrails. Nothing worked.

I tried the SP4 type cover in my local PC World and that didn't work either, but didn't think of trying mine on theirs.

I posted on Microsoft Answers and an MVP suggested that the only thing to try now is a re-image. With gigabytes of software installed on my SP3, a huge amount of stuff to do, and no time to reset the machine.

Grrrr!!!
 

astondg

New member
Jan 7, 2013
409
0
0
Visit site
I had mine stop working. I ininstalled the type cover drivers, rebooted and it worked again

EDIT: I said 'installed' originally, I meant 'uninstalled'
 
Last edited:

Charles Barnhart

New member
Nov 30, 2012
42
0
0
Visit site
I went through all of this when my SP2 type cover suddenly died coincidental to a Windows Insider fast ring update. Tried everything including forced update from MS support. Ultimately, MS support quit supporting. I've concluded it is internal hardware based so I bought a wireless keyboard. Would love to know what is actually wrong.
 

garryknight

New member
Nov 10, 2015
104
0
0
Visit site
Very odd. I just followed the steps here

Me, too. Only there is no "Other Devices" and nothing under Keyboards either.

Does device manager have a filter on by default that hides some devices?

I turned on "Show hidden devices" and there's still no "Other Devices".

I went through all of this when my SP2 type cover suddenly died coincidental to a Windows Insider fast ring update. Tried everything including forced update from MS support. Ultimately, MS support quit supporting. I've concluded it is internal hardware based so I bought a wireless keyboard. Would love to know what is actually wrong.

I think Surface Pros have a hardware fault either inside the type cover itself (bent wires? loose connection?) or inside the type cover connection on the tablet part. But I don't ever have any hope that MS will admit it. They'd just charge far too much to fix it and send it back as "refurbished".

At some point in the future, I'll take it into my local tech guys, see if they can tell what it is.
 

Members online

No members online now.

Forum statistics

Threads
324,098
Messages
2,244,993
Members
428,167
Latest member
CCC