10-15-2016 03:45 PM
84 123 ...
tools
  1. DavidinCT's Avatar
    Now that this has been posted over at WC, this has been something that a bunch of people for months have been working on and although I am not a programmer, I helped out as much as I could.

    So testing this, the install comes from build 10134, with a handful of patched files., and after installed, if you live outside the US, you should get guide data as that comes right from your provider. In the US, our guide data is pulled from Microsoft, that gets it from Zap2it but, now is ROVI....

    The thread is here for people who want to follow the progress (You need to register to view the thread fully)
    [DISCUSSION] Patch WMC to run on Windows 10 final & possible alternatives

    I know a bunch of people who have this installed but, not sure anyone from the US has guide data working or not.

    If you installed this as listed directions here...

    Here is how to install Media Center on Windows 10 | Windows Central

    You might see this error during TV setup....

    guide-issue.jpg

    If you see this error, it seems to not setup guide data, so you will never have guide data from what I have seen.

    I tried isos WITH WMC version all the way back to build 10074 and I still get the same error.

    For those who tried it, does anyone in the US have guide data working ?
    Last edited by DavidinCT; 09-10-2015 at 08:57 AM.
    Laura Knotek and Kevin Rush like this.
    09-07-2015 08:11 PM
  2. Williaml99's Avatar
    Same deal no guide data. Very experienced and have found no trick to fix yet.

    Thanks
    09-07-2015 10:47 PM
  3. bravoland's Avatar
    same results
    09-07-2015 10:58 PM
  4. DavidinCT's Avatar
    Same deal no guide data. Very experienced and have found no trick to fix yet.

    Thanks
    As am I, in the very experienced area of WMC. I have tried the whole book of no-guide issues on WMC and nothing fixes this. SO I even rolled back and built WMC ISOs from Windows 10 builds, installed in VM, used my Ceton Networkable tuner and tried it over an over. Even on build 10074, it did not work.

    I think what needs to happen is this needs to be ripped from 7 or 8.1 and it should resolve this guide data issue. The problem is, the people who were involved with this "hack" are from over seas and over the "pond" they pull guide data from their provider, NOT from Microsoft like people in the US have.

    There are some hacks that you can import guide data in WMC (with some hacks, if Microsoft stops providing data) but, this normally costs a yearly fee.

    Fun, fun, fun... so close but yet so far :(
    09-08-2015 07:27 AM
  5. TechFreak1's Avatar
    David, have you tried a proxy?

    To make it your accessing the MS servers outside of the US as it appears to be a regional block, not sure if that would help or not as have skimmed through the entire thread on MDL but haven't logged in so can't see the masked posts.

    Thus not sure if that has been tried or not.

    And lastly thank you for so being persistent :), others would have surely have given up on trying to get WMC to run Win 10 lol.
    Laura Knotek and Kevin Rush like this.
    09-08-2015 11:18 AM
  6. bravoland's Avatar
    i meant to add that i didn't actually get the error listed it just stays on downloading guide data and the little progress bar never goes past the first dot. after an hour i closed it down and tried again.. same thing.
    09-08-2015 11:21 AM
  7. Williaml99's Avatar
    I have two working 8.1 WMC desktops (my wife and mine) I am testing on my MS Surface 3 pro. Not sure if you could copy the guide data over? Does anyone know?
    Thanks DavidinCT for starting this thread and everyone for the interest. My wife likes WMC and is not ready pay for TIVO at this point so I will maintain WP8.1 or wait for a solid workaround. Also I glad for the hack even if we get no guide data as I usually browse across the network at home and play recorded TV from the desktop wile at the kitchen table eating dinner with my wife. This plays the files better and FF better than VLC or Media Player in my estimation.
    DavidinCT and Kevin Rush like this.
    09-08-2015 12:42 PM
  8. DavidinCT's Avatar
    i meant to add that i didn't actually get the error listed it just stays on downloading guide data and the little progress bar never goes past the first dot. after an hour i closed it down and tried again.. same thing.
    Try this, create a shortcut to C:\Windows\ehome\mcupdate.exe on your desktop.

    When you create that, right click, go to properties, Compatibility, "change settings for all users" , Compatibility: Windows 8 and Check "Run this program as an Administrator"

    Try again after that (if you have WMC opened, Close and re-open), if it hangs on that part, double click your new shortcut you created running MCupdate while your searching, it should help it move along.

    David, have you tried a proxy?

    To make it your accessing the MS servers outside of the US as it appears to be a regional block, not sure if that would help or not as have skimmed through the entire thread on MDL but haven't logged in so can't see the masked posts.

    Thus not sure if that has been tried or not..
    I've tried a few things. Keep in mind, I installed this in 2 machines for testing. One in RTM WIndows 10 (retail upgrade version, NOT in Preview program) and a VM of the same (VM workstation 12).

    The WIndows 10 machine has the hosts file pointed to..
    65.55.5.170 data.tvdownload.microsoft.com
    2.16.216.176 cdn.epg.tvdownload.microsoft.com

    The VM was running on the desktop of Windows 10, but, I rebooted the computer and opened the same VM under WIndows 7, This Windows 7 machine uses Windows Media Center and pulls guide data down fine, so there should be No proxy based issues as it's using NAT.

    As others have reported this issue, I tried to repo it on a VM, so this Installer was created from Windows 10 build 10134, so I built a 10134 VM with WMC (the hack to modify the ISO) and this caused the same exact result. I went back even earlier, and installed 10074, SAME ISSUE. Then today I tried 9901 but, it would not let me even install it (OS expired).

    Trust me, I have been watching log files and the Even viewer almost every hour and I have run TV setup at least 30 times in the last 3 days...AT LEAST.

    I think the test here is to see if we can yank from 7 or 8.1, and pull the WMC WIM from the iso and try to install that version. I think I have gone through what I could here. If it was the installer issue, building a fresh 10134 VM would of worked pulled down the guide fine. This is not the case.

    So, in a nutshell, its something in a change done on Windows 10 that is causing this issue. It's possible that pulling it from Windows 7 or 8.1 still might not work. Or we could get lucky, I just wish I knew Media Center on the programming level to understand EXACTLY how the guide comes down and how it's processed, to really figure out where it's dying off. 6-8 years ago it might of been easier to find, today, not so much.

    If all else fails, we can hack in guide data but, this costs a fee, and I think this might be the point I stop but, there has to be away around it.

    And lastly thank you for so being persistent :), others would have surely have given up on trying to get WMC to run Win 10 lol.
    LOL, thanks, Trust me, I have not even started yet. If it is possible, it will work. I use WMC every day, and not ready to move on as nothing else really seems to give the ease of use here.

    Don't worry, I will only give up when I have completely run out of resources for help and we are not there yet.

    Anyone on here who has a very deep knowledge of Windows Media Center's subsystem want to help out a little ? :)
    09-08-2015 02:44 PM
  9. DavidinCT's Avatar
    Does anyone even get channel line up ? (call letters ?)

    no-call.jpg
    09-08-2015 03:26 PM
  10. HoosierDaddy's Avatar
    I can live without the guide since I don't use Media Center for ANYTHING but running the MediaBrowser (now Emby) add-on. I really don't want to run MC but at the moment, Emby Theatre for Windows doesn't work right (letter-boxes everything) if its running on the same PC as the Emby Server, which has prevented me from installing W10 on our HTPC.

    Pretty weird if I have to hack MC onto W10 when I don't even want MC at all.
    09-08-2015 04:38 PM
  11. bravoland's Avatar
    ok i did the steps you ask and i now get the same error message as everyone ;*(
    09-08-2015 07:30 PM
  12. DavidinCT's Avatar
    ok i did the steps you ask and i now get the same error message as everyone ;*(
    Same with everyone in the US...

    It's currently being investigated. One suggestion is because of update KB3078428 is not installed (the update to ROVI) and others are talking about yanking the files from 8.1 instead of the broken version from Windows 10.

    Shocked that WC posted it on their site with a major part being broken.

    More to come as I know more...
    09-09-2015 07:28 AM
  13. poit57's Avatar
    I'm having this issue with the guide data as well, but I have an even bigger issue. I can play recorded TV from another computer, but I cannot watch live TV. I don't remember the exact error, but it is something indicating that the proper codecs for video playback is missing. I don't know if this is related, but when I run through the WMC setup, the speaker setup doesn't work. It immediately skips to telling me to check my hardware through the control panel. Audio works for video playback and my audio drivers are up to date, so I'm not sure what that is about.

    One thought on the codecs issue is that this might be because I am testing this on the PC that I used for testing the Insider Preview of Windows 10. It was a clean install and not an upgrade from a Windows installation with WMC already installed. Could that be the reason it is reporting missing files for playback? Is there a codec pack that I can download to resolve this issue? All I've found through Microsoft's support pages is old and will not install on Windows 10.
    09-09-2015 08:19 AM
  14. jtpcamp's Avatar
    Go to this site for free codecs. I have used it in the past.
    Codecs.com : Download audio, video codecs and tools
    and install the K-Lite Mega Codec Pack.
    It has always worked for me and others I have recommended it to.
    MakThaNife likes this.
    09-09-2015 08:45 AM
  15. DavidinCT's Avatar
    I'm having this issue with the guide data as well, but I have an even bigger issue. I can play recorded TV from another computer, but I cannot watch live TV. I don't remember the exact error, but it is something indicating that the proper codecs for video playback is missing. I don't know if this is related, but when I run through the WMC setup, the speaker setup doesn't work. It immediately skips to telling me to check my hardware through the control panel. Audio works for video playback and my audio drivers are up to date, so I'm not sure what that is about.

    One thought on the codecs issue is that this might be because I am testing this on the PC that I used for testing the Insider Preview of Windows 10. It was a clean install and not an upgrade from a Windows installation with WMC already installed. Could that be the reason it is reporting missing files for playback? Is there a codec pack that I can download to resolve this issue? All I've found through Microsoft's support pages is old and will not install on Windows 10.
    You can install the Shark007 pack with the default settings or the LAV filers should get live TV working. Some people have run into this. I actually ran into this.

    Did you download the newest installer ? There was a installer updated (revised version) that had some codec fixes on it.

    One of the bigger issues I ran into, if your running a cablecard and have some channels that are DRM'ed. They wont play live. Again this is a work in progress.
    09-09-2015 08:46 AM
  16. poit57's Avatar
    One of the bigger issues I ran into, if your running a cablecard and have some channels that are DRM'ed. They wont play live. Again this is a work in progress.
    That applies to most of my cablecard channels, but I received the message even on local channels that are copy freely. I'll try the codec pack when I get home this evening.

    As for the installer I used, the dropbox link that Windows Central posted was dead by the time I attempted to download. I downloaded from another source that someone linked in the comments on Monday afternoon. I don't know if this would have been the revised installer, but I'm guessing not.
    09-09-2015 09:37 AM
  17. DavidinCT's Avatar
    That applies to most of my cablecard channels, but I received the message even on local channels that are copy freely. I'll try the codec pack when I get home this evening.

    As for the installer I used, the dropbox link that Windows Central posted was dead by the time I attempted to download. I downloaded from another source that someone linked in the comments on Monday afternoon. I don't know if this would have been the revised installer, but I'm guessing not.
    Lucky in my area, there is only 1-2 channels that I have that are protected, I hope this is addressed with when we get the 8.1 files (it's the next step)

    The installer (zip file) has revised at the end of it....

    If you want to keep up with everything and issues, it's here, (you need to register)

    [DISCUSSION] Patch WMC to run on Windows 10 final & possible alternatives
    09-09-2015 10:14 AM
  18. DavidinCT's Avatar
    Oh well, I tried 10036 (old build) and guide data does not work...

    wmc-win10-10036.jpg

    On the plus side, it was tested with 8.1 files and guide is said to be working...
    09-09-2015 04:43 PM
  19. DavidinCT's Avatar
    New files with the 8.1 files just posted, claims working guide....Installing now (If you have the old one installed, there is a uninstaller, UNINSTALL the old one and REBOOT before installing)

    Download WindowsMediaCenter 6.3.9600.0 x64 v1.rar
    09-09-2015 07:43 PM
  20. Williaml99's Avatar
    Seems to work, so far so good.
    Guide, live TV and recording tested.
    DavidinCT likes this.
    09-09-2015 11:21 PM
  21. Tony Clegg's Avatar
    I'm in a similar position to you. WMC is predominantly used for Emby but yet to download. I use Theatre, and there is an option in the settings under EVR (I believe - doing this from memory as at work) but changing to "Just Under" removed the black borders on the four corners. That's really annoying and the team don't seem to be busting a gut to resolve, but it's MS or WMC's issues. Must get my **** in gear and download for Win10 as I miss my WMC.

    I still like the Music program whereby is scrolls slowly all the album covers. That's a nice touch that was added to Win 7's update.
    09-10-2015 04:54 AM
  22. DavidinCT's Avatar
    Tested, confirmed working, for cablecard users too ! Guide data working fine now....

    Test away, the last one was updated to fix permissions but, this should be it...

    X64
    Download WindowsMediaCenter 6.3.9600.0 x64 v2.zip

    X86
    https://mega.nz/#!zAEF0QRQ!dJZ9fzWuy...mfS0QOMzA6UiOI

    Yea ! WMC on WIndows 10 working, I can finally move all my machines over to Windows 10 !

    Now WC should post this on the front page...
    TechFreak1 and markeboyle like this.
    09-10-2015 05:14 AM
  23. theefman's Avatar
    I suppose plugins like Arcsoft TMT work fine as well?
    09-10-2015 05:55 AM
  24. Kevin Rush's Avatar
    Thank you, everyone who worked on bringing WMC to Windows 10. I hope you will post updates regarding issues found and continued stability.
    09-10-2015 06:33 AM
  25. Tony Clegg's Avatar
    Is anyone having an issue with that 32bit link? I downloaded without installing their software initially. It goes through to 99% downloading, sticks at that for a around 20 seconds, then completes, but can't see the download ?...
    09-10-2015 07:05 AM
84 123 ...

Similar Threads

  1. Where are the three dots to select download on groove music?
    By WPCentral Question in forum Ask a Question
    Replies: 1
    Last Post: 09-08-2015, 08:56 AM
  2. [bug thread] Skype Messaging for Windows 10
    By FearL0rd in forum Windows 10 Mobile
    Replies: 1
    Last Post: 09-07-2015, 10:00 PM
  3. Replies: 0
    Last Post: 09-07-2015, 07:46 PM
  4. Twitter for Windows 10 updated with quote-tweet support and 'happening now'
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 09-07-2015, 06:50 PM
  5. Replies: 0
    Last Post: 09-07-2015, 06:22 PM
LINK TO POST COPIED TO CLIPBOARD