1. Zangwill Sher's Avatar
    Running Windows 10 Home Edition, Version 1703 OS Build 15063.332 on desktop computer. I have a file that I cannot delete using an account with full administrative rights. When I tried to take ownership of the file the Advanced tab of the security tab for the files properties shows Owner as "unable to display current owner". I cannot gain any access to this particular file to delete it. I tried to delete file through the DOS command prompt and access was denied. I believe file may be corrupted. Please help.
    06-08-2017 07:50 PM
  2. Kram Devil's Avatar
    From the command line, use ICACLS first, if unsuccessful use TAKEOWN.
    06-08-2017 09:31 PM
  3. Zangwill Sher's Avatar
    Tried following ICACLS command first where <PATH> is the full path to the file.
    Command Prompt: ICACLS "<PATH>\*.*" /grant :r
    Response: "Successfully processed 0 files; Failed processing 1 files"

    Tried Takeown next.
    Command Prompt: takeown /f "<PATH>*.*" /a
    Response: "ERROR: The current logged on user does not have administrative privileges."

    Any other ideas?
    06-08-2017 10:29 PM
  4. Kram Devil's Avatar
    go to the command prompt from winre.
    use delete from there.
    06-09-2017 03:34 AM
  5. Zangwill Sher's Avatar
    What is winre? Please give specifics. Thank you.
    06-09-2017 05:48 AM
  6. orlbuckeye's Avatar
    Typically access denied means something else has the file opened and locked. Like something loaded at startup or part of the OS.
    06-09-2017 09:35 AM
  7. Zangwill Sher's Avatar
    The file is a stand alone executable. Not part of the OS and it is not loaded at startup. The Advanced Properties tab for the file shows that it is unable to display current owner. The directory in which it resides shows that I have full control of the folder, subfolders and files within the directory. If I try to delete the file I get a message that I need permission to perform the action and that I require permission form the computer's administrator to make change to this file.
    06-09-2017 05:21 PM
  8. Chemy JMHT's Avatar
    OK, the times I got some problem like this one I booted from other source and from that I deleted it.

    I think that one who suggested a WINRE means a Windows on CD who can boot the whole system, right now you can have one of USB and also a Lunix Boot USB could help with that.

    Maybe it's something deeper like a problem in one of the FAT tables.
    06-10-2017 04:26 PM
  9. Kram Devil's Avatar
    What is winre? Please give specifics. Thank you.
    Hi Zangwill, sorry about the lack of specifics on that part. The reason for that is because the next steps are really for moderate to advanced PC users only. I wouldn't want to damage your OS just because a file cannot be deleted. It's like taking a sledgehammer to a nail. If you have to ask what WinRE is, then the next steps are probably too dangerous for you to follow. It could result in some unpleasantness up to not being able to boot if you do something wrong.

    Ok, with that disclaimer over, these are the steps you would like to consider if you want to proceed on your own. Please be careful. Please read the steps below first and if you're in any way confused, DO NOT PROCEED. You can't just wing it and hope for the best, you're liable to wreck your PC that way.

    EASIEST STEP BEFORE WINRE:
    1 use a program to delete the file. There are some utilities out there that use DoD methods to wipe the area of the disk where the file was several times so that it cannot be recovered. It doesn't just remove the pointer, it wipes the sectors of the HD. AVG has something like it included in it's AV, it gives you the option to shred a file. There are others out there as well.

    2 If the program cannot delete the file due to access restrictions then it's possible that another process has control or access to it and you would have to determine which one. Use sysinternals process explorer to determine which program has control of it, shutdown the process then attempt to delete.

    3. Start in safemode then attempt to delete the file. Starting your PC in safemode ensures the highest likelihood that no program is accessing the file since non-essential programs do not run in safemode. If this doesn't work then it's WINRE TIME.

    https://support.microsoft.com/en-ca/...c-in-safe-mode


    WINRE - You should know how to use the command prompt to use this step.

    You can create a startup disk and boot from it to reach the winRE but you don't really need to, it's built-in to windows 10. To access winRE you can hold down the shift button while restarting or go to settings > update and security > recovery > advanced startup > restart now. The computer will restart and provide you with options.Select "Troubleshoot" then select "Advanced Options" then "command prompt". If you've locked your harddrives with bitlocker, you would need another computer with internet access to be able to get the keys from the microsoft website to unlock them. After you unlock your drives and the command prompt pulls up, navigate to the file's location and delete it.
    06-11-2017 01:19 AM
  10. mjperry51's Avatar
    Have you tried booting into Safe Mode and deleting? The file could be locked by a driver that loads at startup. . .
    06-11-2017 09:16 AM
  11. orlbuckeye's Avatar
    06-13-2017 09:20 AM
  12. queensoft's Avatar
    Use any Linux Live CD or Linux Live USB flash stick, you can delete anything.
    08-01-2017 07:36 AM

Similar Threads

  1. Can't install QB Pro 2016
    By Windows Central Question in forum Ask a Question
    Replies: 5
    Last Post: 06-19-2017, 10:16 PM
  2. Replies: 0
    Last Post: 06-08-2017, 04:36 PM
  3. How to stop Windows 10 from showing the welcome screen after feature updates
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 06-08-2017, 02:10 PM
  4. Best Gaming Mousepads of 2017
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 06-08-2017, 01:10 PM
LINK TO POST COPIED TO CLIPBOARD