1. AccentAE86's Avatar
    Hey all!

    I've been in the process of building a couple really tiny mobile websites as companions to my full websites. I am a professional photographer and my web stats are showing that about half of my visits are now from mobile phones, so I gotta make a small, quick site optimized for them.

    It's been going decently well, but since I've upgraded my phones to 8.1 Dev Preview, the image rescaling quality is showing some vastly inconsistent results across devices. Before 8.1 DP, if I can recall correctly, everything rendered beautifully. But now, some WP8.1 devices are doing a **** poor job of it. Seeing as how I'm a photographer, I need the images to look proper!

    I've been testing on a variety of phones I own, including a Lumia 1020, 625, 810, 1520, and also a Galaxy S3 and iPhone 4s. The exact same website looks great on the iPhone, S3, and 1520, but looks quite awful on the 1020 and 625, and looks ok on the 810. The 1520 is my only phone not upgraded to 8.1 DP. (I will also later test on my 920, 620, and 520 if I get a chance)

    Here is a crop from the same area for each phone:
    iPhone:


    Galaxy S3:


    Lumia 1520:


    Lumia 810:


    Lumia 1020:


    Lumia 625:


    Look at how horrible the 1020 and 625 look. It's really bothering me and makes me wonder how many visitors are going to see a similarly crappy rendering.

    Here are the full unedited screenshots from each phone:
    iPhone:



    S3:



    1520:



    810:



    1020:



    625:



    So I was just wondering if anyone else was having the same kind of issues with website rendering after updating to 8.1 Dev Preview. If you could do a quick visit to my prototype site and reply in this thread what you see when you look at the gallery, and what device and software version you are running, that would also help me out a lot.

    Link:
    THE BOUDOIR by Night and Day - Edmonton Boudoir Photography

    BTW - the images all look fine in Windows 8.1 IE11 either desktop or metro, so I'm not really looking for tablet visitors. I'm planning for tablet users to go to my full site rather than the mobile site. So I am optimizing this site solely for phones.
    Cheers and thanks so much!
    05-09-2014 11:45 PM
  2. Laura Knotek's Avatar
    Here is how it looks for me. I'm running 8.1 on a Nokia Lumia 920.

    wp_ss_20140510_0001.png

    I wouldn't say it's fuzzy at all.
    05-10-2014 12:45 AM
  3. Guytronic's Avatar
    What was the question and everything looks fine to me.
    05-10-2014 01:12 AM
  4. swervinsuburban's Avatar
    1020 and 625 pixilated panties
    akks likes this.
    05-10-2014 02:58 AM
  5. th0mas96's Avatar
    do you have data sense trying to save your data? That would be a cause for that bad quality..
    05-10-2014 04:08 AM
  6. AccentAE86's Avatar
    do you have data sense trying to save your data? That would be a cause for that bad quality..
    I have turned off compression, so I am viewing everything at full quality. Good thought though!
    05-10-2014 07:20 AM
  7. AccentAE86's Avatar
    Anyone else have insight? Or results to share? Please? I gotta get this figured out!
    05-10-2014 10:41 AM
  8. Ma Rio's Avatar
    Looks decent on my L1520 with 8.0. Sorry I don't have 8.1 to tell you (I'm waiting for the final version /w cyan).
    AccentAE86 likes this.
    05-10-2014 12:52 PM
  9. AccentAE86's Avatar
    Here is how it looks for me. I'm running 8.1 on a Nokia Lumia 920.

    Click image for larger version. 

Name:	wp_ss_20140510_0001.png 
Views:	16 
Size:	379.5 KB 
ID:	66106

    I wouldn't say it's fuzzy at all.
    Thanks Laura, for taking the time to check. I'm thrilled it looks ok for you. I was getting worried that everyone on a windows phone will see a really crappy rendering of my website. This gives me a bit of hope...
    Muessig and Laura Knotek like this.
    05-10-2014 01:15 PM
  10. Muessig's Avatar
    I just tried this out on my 920 and the pictures are loading pixelated for me too. If I save them the picture that saves is high quality and not pixelated, but the quick view picture on the site itself is pixelated. I'll try this on an android device I have in the house and let you know if this is an ie11 issue.
    05-10-2014 01:21 PM
  11. lpforthewin's Avatar
    My 820 running WP8.1 looks like your 625 screenshots I'm afraid :(
    AccentAE86 likes this.
    05-10-2014 01:24 PM
  12. BaritoneGuy's Avatar
    A bit pixilated on my 1520 running 8.1 for the thumbnails. When selected individually the pictures look fine.
    AccentAE86 likes this.
    05-10-2014 03:40 PM
  13. Dratwister's Avatar
    pixelated on 920 using W8.1.
    Tested on both Wifi and 3G. This's really a weird problem as I've never seen this issue on any other image sites
    AccentAE86 likes this.
    05-11-2014 01:21 PM
  14. AccentAE86's Avatar
    Thumbnails are very pixelated, but the photos themselves are not pixelated on my Lumia 1020 with 8.1, not to my eyes anyway:

    Attachment 66128
    thanks for posting the screenshot. You see, you are using the same phone and same OS version I am, yet it looks different for you than it does for me. That's why this is such a head scratcher! Reading all the responses, it looks like the results are pretty mixed. Having inconsistent results makes it extremely hard to troubleshoot. argh...

    Thank you to all who helped! If anyone else is reading this, please post your results too please!!
    05-11-2014 05:09 PM
  15. BaritoneGuy's Avatar
    thanks for posting the screenshot. You see, you are using the same phone and same OS version I am, yet it looks different for you than it does for me. That's why this is such a head scratcher! Reading all the responses, it looks like the results are pretty mixed. Having inconsistent results makes it extremely hard to troubleshoot. argh...

    Thank you to all who helped! If anyone else is reading this, please post your results too please!!
    I would reach out to MS via the developers sites. This site while very active is mostly a bunch a very excellent enthusiasts. There must be something on MSDN for you to turn to for help.
    05-11-2014 05:20 PM
  16. AccentAE86's Avatar
    Well, got my hands on another 1020 running 8.1, just like mine. And it renders the images beautifully. WTF? This is driving me crazy. I don't think I'll ever get to the bottom of this.
    Laura Knotek likes this.
    05-14-2014 05:03 PM
  17. Lundon44's Avatar
    I had a very similar problem on my 920 about a year ago. But obviously this was well before 8.1. My issue was that ANY images rendered from the internet on everything (ie. apps, IE, Das Image, Bing) across my device came out looking almost 16bit. Everything from the thumbnails on Fhotoroom to any images on websites on IE... Didn't matter what it was. Even banner images and embedded ads on websites were pixelated. Nokia didn't know or understand the issue and it seemed for me to be an isolated issue at the time since no one else on WPCentral or XDA Devs could figure out the problem. In the end a hard reset solved my problem. Obviously I wouldn't suggest that.

    And btw, that image on my 1520 with 8.1 is not quite as pixelated but a cross between your 1020 and your iPhone:wp_ss_20140516_0002.jpg
    05-16-2014 01:07 PM
  18. AccentAE86's Avatar
    I had a very similar problem on my 920 about a year ago. But obviously this was well before 8.1. My issue was that ANY images rendered from the internet on everything (ie. apps, IE, Das Image, Bing) across my device came out looking almost 16bit. Everything from the thumbnails on Fhotoroom to any images on websites on IE... Didn't matter what it was. Even banner images and embedded ads on websites were pixelated. Nokia didn't know or understand the issue and it seemed for me to be an isolated issue at the time since no one else on WPCentral or XDA Devs could figure out the problem. In the end a hard reset solved my problem. Obviously I wouldn't suggest that.

    And btw, that image on my 1520 with 8.1 is not quite as pixelated but a cross between your 1020 and your iPhone:
    Interesting... seems like these are isolated cases, but it also seems like this is more common now than it was a year ago. So strange. I might hard reset my phones to see if it helps. Thanks for your feedback, it helps!
    05-16-2014 04:46 PM
  19. Kilerden's Avatar
    Nokia Lumia 920 wp8.1 dev. preview.
    The images are not pixelated. (only the thumbnails)

    Maybe it's because the images open up in a pop up?
    05-16-2014 05:58 PM

Similar Threads

  1. VPN issue..
    By lempo in forum Windows Phone 8.1 Preview for Developers
    Replies: 3
    Last Post: 06-02-2014, 12:04 PM
  2. Add artist image to music ?
    By rizzo183 in forum Windows Phone 8.1 Preview for Developers
    Replies: 2
    Last Post: 05-11-2014, 05:39 PM
  3. HELP! Issue with Surface Touch Cover
    By ians18 in forum Microsoft Surface for Windows RT
    Replies: 1
    Last Post: 05-10-2014, 04:00 PM
  4. Surface 2 micro HDMI out - no audio working on TV?
    By Ed Boland in forum Microsoft Surface 2
    Replies: 3
    Last Post: 05-10-2014, 11:03 AM
  5. Wifi issues
    By The1Weapon in forum Microsoft Surface 2
    Replies: 0
    Last Post: 05-09-2014, 04:21 PM
LINK TO POST COPIED TO CLIPBOARD