1. AndyCalling's Avatar
    I need quick help so I can return this if needed. Just got an MS Display Dock to connect my Lumia 950 XL to stuff. Dock firmware is updated. Phone is on latest stable W10 public release. Every time I plug the dock in to my phone the phone complains that I am using the wrong USB C cable and that I should use the one that comes with the dock. Of course, that's the one I'm using because I don't have any other. Whilst USB and HDMI work fine, DisplayPort does nothing. Also, though it often charges when plugged in to the hub, equally often it does not. Now, is the USB cable error just one of those lovable W10 quirks that everyone gets? I saw one old thread from 2015 that suggests this may be the case, but I'm not sure. the HDMI TV works, but the monitor using DisplayPort does not. Could that be because the monitor goes up to 144Hz? I would have thought the Display Dock would have run it at 1080p 60Hz? DP cable works well with my GTX 1080 using GSYNC and meets all standards. I'm thinking this is a faulty unit, but is this behaviour to be expected? Should I return immediately? Thanks for your help folks.
    02-20-2017 03:29 PM

Similar Threads

  1. Windows 10 offline defender will not run from usb drive
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 02-20-2017, 03:22 PM
  2. Replies: 0
    Last Post: 02-20-2017, 02:27 PM
  3. Windows Launch and Cortana does not work
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 02-20-2017, 12:14 PM
  4. Microsoft's Surface phone should be much more than just a 'phone'
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 02-20-2017, 11:11 AM
  5. WhatsApp not working on Lumia 640 on RS2
    By gamo62 in forum Applications
    Replies: 0
    Last Post: 02-20-2017, 03:31 AM
LINK TO POST COPIED TO CLIPBOARD