Random restarts-950XL

aimulaidni

New member
Nov 4, 2012
192
0
0
Visit site
Hi everyone,

I updated my lumia 950XL to 14393.576 sometime back and since then the phones been rebooting or shutting down a lot randomly. Like I'll be in the middle of a call or opening an application or typing a message and it would either restart or the phone screen would just go blank. It's practically unusable right now. And sometimes when I try to reboot it, it just gives me the dead battery sign even though there's plenty of juice left in it. For example, this morning I went out to get breakfast and my phone just died. And I know it had around 80% battery left. When I came back home and plugged it in, it showed me there was still 75% left. I tried soft and hard reset and none seem to be working. And I'm not sure if I should take it to the microsoft store because my warranty ended last month and I don't think I want to pay for my phone's repair, especially because it's not something that I did.

Anyone else having these issues?
 

Player Piano

New member
Jan 18, 2016
341
0
0
Visit site
I'm so mad right now...and feel helpless...if I could strangle someone at Microsoft right now, I would...This phone and Win10m have been nothing but a disaster for me
Yeah I hear you loud and clear. Hard to believe this mess has been in the hands of the public for a year already and still feels beta.
 

Joe920

Active member
Nov 13, 2012
1,677
0
36
Visit site
Mine's starting to act up as well. I though I was one of the lucky ones, but alas.. Running Slow Ring build 14965. I find that the screen stays dark when I wake the phone with the camera button, but it turns out it's still taking pictures in that mode. Hitting power will show that the camera is active. I get hot pocket syndrome and reboots. Just now I hit power to check whatsapp, and the screen just went blank. No way out but to use power+voldown. What a mess.

Is the fast ring any better? Or are we just SOL unless we flash the stable release? Not a happy camper..
 

MAK11

New member
Jul 21, 2016
42
0
0
Visit site
How many threads are we going to have about this particular issue? Why don't people use the search function in the forums before posting?

Anyway...If your 950/950 XL suffer from random reboots/strange battery level reports etc YOUR BATTERY IS BUSTED. Plain & simple. The only fix is to get a new battery. No amount of flashing/resetting is going to change anything to your situation. There are plenty of users all over the world who have already reported these issues and just had to get a new battery.
 

Player Piano

New member
Jan 18, 2016
341
0
0
Visit site
I think MAK11 is having issue with the difference between association and causation. For me, when I first bought the L950 at launch, I dealt with random reboots. A few builds later no more random reboots. So initially I had random reboots along with a normal functional battery. For many months I did not experience any random reboots, and now all of a sudden they are back. And now I can determine that every single random reboot I experience more recently occurs only when Wi-Fi is turned on, and I am reach the limit of the range for my router. So for my case I am quite confident that the random reboots are not due to a bad battery, but OS related.
 

Joe920

Active member
Nov 13, 2012
1,677
0
36
Visit site
So for my case I am quite confident that the random reboots are not due to a bad battery, but OS related.
Same here. For me it happens around using the camera, and only recently. For me that all but rules out the battery. It's actually getting worse, it almost seemed like the phone was in a boot loop. It wouldn't get past the windows logo. Sheesh..

So if I may ask again, are things better on the fast ring? Has anyone tried to 'move up' to see if it helped?
 

Player Piano

New member
Jan 18, 2016
341
0
0
Visit site
Same here. For me it happens around using the camera, and only recently. For me that all but rules out the battery. It's actually getting worse, it almost seemed like the phone was in a boot loop. It wouldn't get past the windows logo. Sheesh..

So if I may ask again, are things better on the fast ring? Has anyone tried to 'move up' to see if it helped?
Mine is getting worse day by day as well. I haven't jumped to the slow/fast ring, am curious to find out what others are experiencing too.
 

aimulaidni

New member
Nov 4, 2012
192
0
0
Visit site
Same here. For me it happens around using the camera, and only recently. For me that all but rules out the battery. It's actually getting worse, it almost seemed like the phone was in a boot loop. It wouldn't get past the windows logo. Sheesh..

So if I may ask again, are things better on the fast ring? Has anyone tried to 'move up' to see if it helped?

I haven't tried the insider program. I'm not sure if that would help but that seems to be the only thing left that I can try out now. My phone isnt getting any better and the fact that these people wont come out with any new builds before the new year makes me wonder if I'll be able to use this phone at all till then.
 

Joe920

Active member
Nov 13, 2012
1,677
0
36
Visit site
Mine is getting worse day by day as well. I haven't jumped to the slow/fast ring, am curious to find out what others are experiencing too.
Well I'm taking the plunge, I'm installing the fast ring. I somehow doubt it will fix this, but with a bit of luck it will work like a phone for a few days.

In the meantime, have people successfully flashed back from the RS build to the stable build and restored from RS backup?

Sent from mTalk, a great Tapatalk alternative
 

aimulaidni

New member
Nov 4, 2012
192
0
0
Visit site
Well I'm taking the plunge, I'm installing the fast ring. I somehow doubt it will fix this, but with a bit of luck it will work like a phone for a few days.

In the meantime, have people successfully flashed back from the RS build to the stable build and restored from RS backup?

Sent from mTalk, a great Tapatalk alternative

Hmmm... That is an interesting question... Never really tried it... Could you let us know if it works for you?
 

Joe920

Active member
Nov 13, 2012
1,677
0
36
Visit site
Hmmm... That is an interesting question... Never really tried it... Could you let us know if it works for you?
I will post back here with my findings. Just finished updating to the fast ring, no crashes yet in the first minute. :D

Sent from mTalk, a great Tapatalk alternative
 

Minh Junior Dinh

New member
Dec 21, 2016
158
0
0
Visit site
Actually, I own a Lumia 950xl when it was on sale for 450AU in Australia, that's a steal. However, I also experience these issues. Also, they seem to be prevalent on most Lumia 950 phones. It only restarts occasionally when I am using it. Windows 10 on phones are buggy, but they are improving, slowly.
 

Simon Edmunds

New member
Oct 19, 2016
20
0
0
Visit site
Had my 950xl for 4 months, and using release preview but so far only had the phone restart once. Has worked fine so far. Am counting my blessings that I have not had this issue yet.
 

lucky4ansh

New member
Oct 13, 2013
49
0
0
Visit site
Check your battery once. If it reboots after a specific percentage, then time to replace the battery. My phone used to reboot when it touched 60% everytime. I checked the battery and it was swollen. To check if its swollen, place it on a flat surface and rotate it. If it rotates, time to order a new battery.
 

aimulaidni

New member
Nov 4, 2012
192
0
0
Visit site
Check your battery once. If it reboots after a specific percentage, then time to replace the battery. My phone used to reboot when it touched 60% everytime. I checked the battery and it was swollen. To check if its swollen, place it on a flat surface and rotate it. If it rotates, time to order a new battery.


I did... And I tried the spin test as well... It's not swollen...but it does seem to be happening after the battery goes below 50%...I'll put it on a dial indicator and see if it's completely flat or not
 

Members online

Forum statistics

Threads
324,228
Messages
2,245,190
Members
428,180
Latest member
TheStivo